Obshutdown, nova versão e modo de instalação


O Obshutdown é um gestor de seção para o OpenBox, sobre o qual fiz um artigo para o VivaoLinux.

O problema é que recentemente o pacote com o código-fonte não está mais disponível, então pesquisando no AUR encontrei uma nova versão e é sobre ela e sobre o novo método de instalação que falarei aqui.

No Arch Linux é muito fácil instalar esse programa:

$ wget https://aur.archlinux.org/packages/ob/obshutdown-git/obshutdown-git.tar.gz
$ tar -zxf obshutdown-git.tar.gz
$ cd obshutdown-git
$ makepkg -si

E facilmente o pacote é baixado, compilado e instalado:

Nas distros Debian-based, desde que o GIT está instalado, faremos assim:

$ git clone https://github.com/panjandrum/obshutdown.git
$ cd obshutdown
$ ./configure --prefix=/usr && make -j2
$ sudo make install

Ou para gerar um .deb:

$ sudo checkinstall -D --install=no --pkgarch=all
$ sudo dpkg -i obshutdown_0.1-rc1-1_all.deb

Tendo concluído o empacotamento ou a instalação do pacote, crie um arquivo .obshutdown.rc em seu diretório pessoal:

$ cd
$ nano .obshutdown.rc

E cole o conteúdo abaixo:

#
# Openbox shutdown dialog
# This is example obshutdown rc file
# Copy this file to ~/.obshutdown.rc and customise
#

[general]
version = 0.1-beta2
verbose = false
default_action = shutdown
composite = true
theme = faenza
buttons = cancel logout shutdown restart

[actions]
logout = openbox --exit
shutdown = dbus-send --print-reply --system --dest=org.freedesktop.Hal /org/freedesktop/Hal/devices/computer org.freedesktop.Hal.Device.SystemPowerManagement.Shutdown
restart = dbus-send --print-reply --system --dest=org.freedesktop.Hal /org/freedesktop/Hal/devices/computer org.freedesktop.Hal.Device.SystemPowerManagement.Reboot
lock =
switch =
suspend =
hibernate =
custom =

[shortcuts]
logout = l
shutdown = s
restart = r
lock =
switch =
suspend =
hibernate =
custom =

[labels]
cancel = CANCELAR
logout = SAIR
restart = REINICIAR
shutdown = DESLIGAR
lock = TRAVAR PC
switch = TROCAR USUÁRIO
suspend = SUSPENDER
hibernate = HIBERNAR
#

Ou se quiserem usem o arquivo de exemplo localizado em /usr/share/obshutdown/example.rc

O tema poderá ser alterado por um dos disponíveis em /usr/share/obshutdown/themes.

Até a próxima!

Anúncios
Obshutdown, nova versão e modo de instalação

14 comentários sobre “Obshutdown, nova versão e modo de instalação

  1. Lá nessa página do github existe um rc1. Ele é muito antigo? Nunca usei esse obshutdown, mas acho ele bonito pra caramba! Acho que no gnome ele talvez não fosse uma boa ideia, se é que funcionasse. =/Abraços e sempre uma boa contribuição rapaz!

    Curtir

  2. Sobre a versão RC1 citada pelo nobre colega eis os passos:$ wget http://cloud.github.com/downloads/panjandrum/obshutdown/obshutdown-0.1-rc1.tar.gz$ tar -zxvf obshutdown-0.1-rc1.tar.gz$ cd obshutdown-0.1-rc1$ ./configure && make $ sudo make install # para aqueles que não queiram empacotá-lo com o Checkinstall.ou$ sudo checkinstall -D # constrói um pacote Debian$ sudo checkinstall -S # constrói um pacote para Slackware$ sudo checkinstall -R # constrói um pacote para distros RPM-like

    Curtir

  3. Caramba, Edinaldo!Não consigo instalar no Cruchbang. Faz um tempo que estou tentando.O comando './configure' não gera o pacote 'makefile'. Sempre pede um pacote que já instalei. E um monte de outros que pesquisei sobre e já estão instalados.Acho que em matéria de pacotes e libs para compilação, meu Crunchbang está praticamente um Slackware. rs Depois do './configure', retorna isto:—————-./configure: line 3406: CHECK_EXPORT_DYNAMIC: command not foundchecking for pkg-config… /usr/bin/pkg-configchecking pkg-config is at least version 0.9.0… yeschecking for GTK… noconfigure: error: Package requirements (gtk+-2.0) were not met:No package 'gtk+-2.0' foundConsider adjusting the PKG_CONFIG_PATH environment variable if youinstalled software in a non-standard prefix.Alternatively, you may set the environment variables GTK_CFLAGSand GTK_LIBS to avoid the need to call pkg-config.See the pkg-config man page for more details.——————-Já tô avéxado, homi! rsNão tenha pressa em responder.Abração brother!

    Curtir

  4. BoasNão consegui instalar, recebo o seguinte erroabdo@jatubuntu:~/obshutdown$ ./configure && make configure: error: cannot find install-sh, install.sh, or shtool in "." "./.." "./../.."e os links dos pacotes debian caem numa pagina de erro 404 do dropboxabcsabdo

    Curtir

  5. camarada, continuei a ter esse erro aí, enunciado pelo abdo.
    “configure: error: cannot find install-sh, install.sh, or shtool in “.” “./..” “./../..” ”
    tem alguma ideia do que possa ser isso?
    tou correndo debian testing 64bit.
    kudos

    Curtir

      1. edps disse:

        Vi o log e de fato está muito estranho, o erro já é no começo.

        Pule o passo:

        $ ./configure –prefix=/usr && make -j2

        Para:

        $ ./configure –prefix=/usr && make

        A explicação: às vezes aumentar o nº de jobs na compilação acarretam em erros, veja se compilando assim resolve.

        Curtir

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s