XFCE 4.10 no Debian (um novo método)


Após uma breve pausa nas postagens devido a correria no trabalho, demonstrarei aqui como instalar o XFCE 4.10 no Debian Wheezy.

Aqui faremos uso de um repositório do Siduction, vamos lá?

Comecemos por adicionar as seguintes linhas ao arquivo /etc/apt/sources.list:

### ---------------------------
### XFCE 4.10 (siduction repo).
### ---------------------------
### Chave GPG: wget -nv http://ftp.spline.de/pub/siduction/base/pool/main/s/siduction-archive-keyring/siduction-archive-keyring_2012.07.01_all.deb && sudo dpkg -i siduction-archive-keyring_2012.07.01_all.deb
deb http://ftp.spline.de/pub/siduction/xfcenext unstable main

A seguir prosseguimos instalando o arquivo de chaves de autenticação da distro, atualizamos o sources.list e instalamos o novo XFCE…

$ wget -nv http://ftp.spline.de/pub/siduction/base/pool/main/s/siduction-archive-keyring/siduction-archive-keyring_2013.03.29_all.deb
$ sudo dpkg -i siduction-archive-keyring_2013.03.29_all.deb
$ sudo apt-get -f install
$ sudo apt-get update
$ sudo apt-get dist-upgrade
$ sudo apt-get -t unstable install xfce4 xfce4-goodies

Em caso de erro na instalação da chave GPG, seja pela modificação da versão do pacote ou por outro motivo, sugiro o uso dos comandos abaixo:

$ sudo apt-get update
$ sudo apt-get install siduction-archive-keyring
$ sudo apt-get update

Como visto numa das imagens, 14 pacotes deixaram de ser atualizados, resolvi o problema assim:

$ sudo apt-get -t unstable dist-upgrade

Após a instalação e se desejarem removam as linhas do sources.list:

Esta dica foi testada no Debian Wheezy, não garanto que vá funcionar no Debian Squeeze, mas se quiserem adicionem o repo citado e simule uma instalação e vejam o resultado:

$ sudo apt-get update
$ sudo apt-get -t stable dist-upgrade
$ sudo apt-get -t unstable install xfce4 xfce4-goodies -s
$ sudo apt-get -t unstable dist-upgrade -s

Este slideshow necessita de JavaScript.

Referência:

http://news.siduction.org/

Anúncios
XFCE 4.10 no Debian (um novo método)

18 comentários sobre “XFCE 4.10 no Debian (um novo método)

  1. edps disse:

    @abneto, você pode tentar pelo menos.

    1. adicione os repos
    2. atualize as listas de pacotes
    3. siga os passos sugeridos antes do slideshow:

    $ sudo apt-get -t unstable install xfce4 xfce4-goodies -s
    $ sudo apt-get -t unstable dist-upgrade -s

    E se nada de anormal for relatado atualize|ou| instale esse XFCE. Na dúvida crie um post no VOL e posta a saída dos 2 comando acima (eles apenas simulam, nada vai ocorrer ao teclar ENTER), para instalar pra valer basta retirar a opção -s.

    Curtir

    1. edps disse:

      Beleza! eu voltei a usar o OpenBox para mim o melhor.

      Infelizmente para usar o XFCE4.10 no Wheezy mesmo quando lançado teremos que utilizar ou esse método ou usar os pacotes do SID, me parece que em março já estárá sendo lançada a versão 4.12.

      Um abraço.

      Curtir

      1. abneto disse:

        Pensei que estava tudo certo mas agora foi aparendo alguns probleminhas…
        Alguns itens do menu sumiram mesmo após reiniciar o mesmo não aparece, por exemplo “Encerrar sessão” e outro mudou de posição… o painel inferior ficou desconfigurado e não consegui resolver… a area de notificação (icone do volume, rede, bateria, data e hora do sistema) estão alinhado a esquerda, não fica mais a direita… estou tentando achar uma solução!!!

        Nunca usei esse OpenBox… vou ver se acho algum post seu aqui sobre ele e vou testar para conhecer…

        Vlw

        Curtir

  2. edps disse:

    @abneto, sugiro que remova as configurações do XFCE:

    $ rm -rfv ~/.cache/*
    $ rm -rfv ~/.config/xfce*

    Porque esse problema do painel zoneado é antigo, assim logo ao acessar novamente o XFCE você será perguntado sobre como quer o painel, escolha a opção padrão (2 painéis) e modifique de acordo com sua necessidade, esse erro vem desde o XFCE 4.8.

    Curtir

  3. abneto disse:

    edps…
    Estou com mais um probleminha hehe…

    Agora tem varios pacotes que não são mais necessários… veja:

    abneto@debian:~ $ sudo apt-get install audacious-plugins
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    audacious-plugins já é a versão mais nova.
    audacious-plugins configurado para instalar manualmente.
    Os seguintes pacotes foram instalados automaticamente e já não são necessários:
    ant ant-optional brasero brasero-common cdrdao crda dnsmasq-base fonts-sil-gentium fonts-sil-gentium-basic gimp gimp-data gir1.2-gnomebluetooth-1.0
    gnome-accessibility-themes gnome-bluetooth gnome-themes-standard gnome-themes-standard-data gstreamer0.10-chromaprint gstreamer0.10-plugins-ugly gtk2-engines
    hyphen-en-us iw liba52-0.7.4 libamd2.2.0 libao-common libao4 libapache-pom-java libaudio2 libavcodec54 libavformat54 libbabl-0.1-0 libbrasero-media3-1
    libchromaprint0 libcolamd2.7.1 libcommons-beanutils-java libcommons-collections3-java libcommons-compress-java libcommons-digester-java libcommons-logging-java
    libcommons-parent-java libdb-java libdb-je-java libdb5.1-java libdb5.1-java-jni libdbusmenu-glib4 libdiscid0 libdvbpsi7 libebml3 libgegl-0.2-0 libgimp2.0
    libgmime-2.6-0 libgnome-bluetooth10 libgpod-common libgpod4 libhsqldb-java libicu4j-java libilmbase6 libindicate-gtk3 libindicate5 libiso9660-8 libjaxp1.3-java
    libjim0debian2 libjline-java libjtidy-java liblightdm-gobject-1-0 liblua5.1-0 liblucene2-java libmad0 libmatroska5 libmng1 libmpeg2-4 libnetfilter-conntrack3
    libnl-route-3-200 libnm-glib-vpn1 libnm-glib4 libnm-gtk-common libnm-gtk0 libnm-util2 libobrender27 libobt0 libopenexr6 libopenraw1 libpostproc52 libqtcore4
    libqtgui4 libquvi-scripts libquvi7 libregexp-java libreoffice libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-draw libreoffice-emailmerge
    libreoffice-filter-binfilter libreoffice-filter-mobiledev libreoffice-gtk libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-math
    libreoffice-report-builder-bin libreoffice-writer libsdl-image1.2 libservlet2.5-java libsidplay1 libspeexdsp1 libswscale2 libtar0 libtidy-0.99-0 libtotem-plparser17
    libtracker-sparql-0.14-0 libtwolame0 libumfpack5.4.0 libunistring0 libupnp6 libva-x11-1 libvcdinfo0 libvisio-0.0-0 libvlc5 libvlccore5 libwebp2 libwmf0.2-7
    libwpd-0.9-9 libwpg-0.2-2 libwps-0.2-2 libx264-123 libx264-129 libxalan2-java libxcb-composite0 libxcb-keysyms1 libxcb-randr0 libxcb-xv0 libxerces2-java
    libxml-commons-external-java libxml-commons-resolver1.1-java libxz-java lightdm lightdm-gtk-greeter lp-solve media-player-info mobile-broadband-provider-info
    modemmanager mythes-en-us network-manager network-manager-gnome obexd-client python-cddb python-feedparser python-gpod python-gst0.10 python-indicate python-mmkeys
    python-musicbrainz2 python-mutagen python-pyinotify python-uno python-utidylib ttf-liberation ttf-sil-gentium-basic usb-modeswitch usb-modeswitch-data vlc vlc-data
    vlc-nox vlc-plugin-notify vlc-plugin-pulse wireless-regdb xsane xsane-common
    Utilize ‘apt-get autoremove’ para os remover.
    0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
    abneto@debian:~ $

    Pelo que vi são pacotes necessários… se eu remover estarei removendo quase o ambiente inteiro… Tem como resolver isso??? Ou pode ser minha source.list que esta incorreta??

    Curtir

    1. edps disse:

      Pelo que vi há alguns conflitos entre os pacotes do seu sistema, quem sabe devido ao uso de um repositório diferente.

      Em particular ao uso dessa dica, os repos do siduction devem ser desabilitados após a instalação do XFCE.

      Sugiro que abra um post no VOL onde informe o conteúdo de seu sources.list, se quiser que dê uma olhada posta no paste.bin e informe o endereço e qual a versão do Debian que usa.

      Um abraço.

      Curtir

      1. edps disse:

        Então, acontece que esses diabos de meta-pacotes quando são removidos deixam uma série de pacotes soltos no sistem, foi o que aconteceu ai, se quiser remover o gnome e deixar so XFCE comece por:

        apt-get –purge remove gnome gnome-desktop-environment gnome-core

        Mas… novamente ficarão pacotes soltos, remover todo o gnome dá muito mais trabalho que remover XFCE até mesmo o KDE, o ideal é que vc abra Synaptic e vá removendo um a um, sempre observando o campo INSTALADOS LOCAL OU OBSOLETO e CONFIGURAÇÃO RESIDUAL.

        Provavelmente muitos outros pacotes terão que ser removidos para depois ser reinstalados.

        Acho que não vale a pena, o melhor é se quer mesmo usar o XFCE baixe a versão LXDE/XFCE e depois atualize o XFCE com esse repo do siduction.

        Boa sorte.

        Curtir

  4. abneto disse:

    Obrigado pela ajuda edps… instalando os pacotes gnome* o meu audio que não era reconhecido no XFCE agora esta funfando certinho… algum pacote que foi instalado e reconheceu o audio, não sei qual foi mas sei que agora esta redondinho meu sistema!!!

    Vou deixar assim mesmo… já tinha testado o gnome3 no fedora e não gostei muito (quase nada) mas vou deixar e mexer um pouco quem sabe mudo de idéia… meu objetivo agora é não formatar mais meu debian… pois costumo fazer isso no minimo 4x no mes!!!

    Att

    Curtir

    1. edps disse:

      É porque houve mudança na chave GPG, agora o endereço é este:

      http://ftp.spline.de/pub/siduction/base/pool/main/s/siduction-archive-keyring/siduction-archive-keyring_2013.03.29_all.deb

      E a instalação assim:

      $ wget -nv http://ftp.spline.de/pub/siduction/base/pool/main/s/siduction-archive-keyring/siduction-archive-keyring_2013.03.29_all.deb
      $ sudo dpkg -i siduction-archive-keyring_2013.03.29_all.deb
      $ sudo apt-get -f install

      ou tente esta outra forma (recomendado):

      $ sudo apt-get update
      $ sudo apt-get install siduction-archive-keyring
      $ sudo apt-get update

      Um abraço.

      Curtir

  5. Os pacotes a seguir têm dependências desencontradas:
    xfce4 : Depende: xfwm4 (>= 4.10.0) mas não será instalado
    Depende: xfce4-settings (>= 4.10.0) mas não será instalado
    Depende: xfce4-panel (>= 4.10.0) mas 4.8.6-4 está para ser instalado
    Depende: xfdesktop4 (>= 4.10.0) mas não será instalado
    Depende: thunar (>= 1.4.0) mas 1.2.3-4+b1 está para ser instalado
    Depende: xfce4-session (>= 4.10.0) mas não será instalado
    Depende: xfce4-appfinder (>= 4.10.0) mas não será instalado
    Depende: libxfce4ui-utils (>= 4.10) mas não é instalável
    Recomenda: thunar-volman (>= 0.8.0) mas não será instalado
    Recomenda: tango-icon-theme (>= 0.8.90) mas não será instalado
    Recomenda: xfce4-notifyd mas não será instalado
    xfce4-goodies : Depende: thunar-archive-plugin mas não será instalado
    Depende: thunar-media-tags-plugin mas não será instalado
    E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

    Como posso corrigir isso para instalar o 4.10 e não o 4.08?

    Curtir

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s