Kernel Liquorix e Wine 1.5 no Debian


Instalação do kernel Liquorix e do Wine 1.5 no Debian.

Dica de demonstração apenas, afinal o endereço onde os pacotes serão obtidos foram citados na seguinte dica:

Mas para facilitar adicione as linhas abaixo em seu arquivo /etc/apt/sources.list ou em /etc/apt/sources.list.d/liquorix.list:

### ----------------
### Kernel Liquorix.
### ----------------
### Chave GPG: sudo apt-get install '^liquorix-([^-]+-)?keyring.?'
deb http://liquorix.net/debian/ sid main


liquorix+wine-001

Após salvar o arquivo, execute os seguintes comandos:

# apt-get update
# apt-get install '^liquorix-([^-]+-)?keyring.?'
# apt-get update

E prossiga com a instalação dos pacotes com:

# apt-get install linux-image-liquorix-686 linux-headers-liquorix-686 wine winetricks cabextract


liquorix+wine-002

liquorix+wine-003

Em relação ao kernel Liquorix, substitua -686 por -amd64 se for seu caso.

Abaixo vejam meu Wheezy com kernel Liquorix rodando o player AIMP no Wine.


liquorix+wine-004

Outras formas de instalação do Wine podem ser vistas nos artigos abaixo:

Anúncios
Kernel Liquorix e Wine 1.5 no Debian

11 comentários sobre “Kernel Liquorix e Wine 1.5 no Debian

  1. hiltongil disse:

    Liquorix é muito bom. Utilizo ele bastante. Gosto também do kernel PF. Para quem utiliza o Debian e derivados o scrip smxi possibilita a instalação dentre outros do kernel liquorix.

    Curtir

    1. edps disse:

      Beleza brother!

      Infelizmente com o passar do tempo deverá ocorrer o mesmo problema do Liquorix com o Wheezy (e antes com o Squeeze), o das dependências, como o gcc entre outros.

      A solução é migrar as configs do Wheezy para Wheezy Backports, por enquanto não, mas no futuro provavelmente, o meu já está setado como tal:

      APT::Default-Release wheezy-backports;
      APT::Get::Purge 1;
      APT::Cache-Limit 30000000;
      APT::Get::AllowUnauthenticated 0;
      APT::Get::AutomaticRemove 1;
      APT::Get::HideAutoRemove 1;
      APT::Install-Recommends 0; ### mas é bom deixar como 1.
      APT::Install-Suggests 0;
      Aptitude::Recommends-Important 1;
      Debug::pkgAutoRemove 0;
      Acquire{
      HTTP::proxy “http://127.0.0.1:3128”;
      FTP::proxy “http://127.0.0.1:3128”;
      }
      Acquire::Languages none;
      Acquire::cdrom::Mount /media/cdrom;
      Acquire::PDiffs 0;
      Acquire::http::timeout “10”;
      DPkg
      {
      Options {–force-overwrite;}
      }

      Curtir

  2. jumesyn disse:

    certo.
    e onde eu coloco essas linhas?:

    APT::Default-Release wheezy-backports;
    APT::Get::Purge 1;
    APT::Cache-Limit 30000000;
    APT::Get::AllowUnauthenticated 0;
    APT::Get::AutomaticRemove 1;
    APT::Get::HideAutoRemove 1;
    APT::Install-Recommends 0; ### mas é bom deixar como 1.
    APT::Install-Suggests 0;
    Aptitude::Recommends-Important 1;
    Debug::pkgAutoRemove 0;
    Acquire{
    HTTP::proxy “http://127.0.0.1:3128″;
    FTP::proxy “http://127.0.0.1:3128″;
    }
    Acquire::Languages none;
    Acquire::cdrom::Mount /media/cdrom;
    Acquire::PDiffs 0;
    Acquire::http::timeout “10″;
    DPkg
    {
    Options {–force-overwrite;}
    }

    Curtir

    1. edps disse:

      Assim meu quirido (exemplo que remove os meta-packages, kernel e headers propriamente dito):

      # apt-get –purge remove linux-image-liquorix-686 linux-headers-liquorix-686 linux-image-3.8-13.dmz.1-liquorix-686 linux-headers-3.8-13.dmz.1-liquorix-686
      Lendo listas de pacotes… Pronto
      Construindo árvore de dependências
      Lendo informação de estado… Pronto
      Os pacotes a seguir serão REMOVIDOS:
      linux-headers-3.8-13.dmz.1-liquorix-686* linux-headers-liquorix-686*
      linux-image-3.8-13.dmz.1-liquorix-686* linux-image-liquorix-686*
      0 pacotes atualizados, 0 pacotes novos instalados, 4 a serem removidos e 14 não atualizados.
      Depois desta operação, 155 MB de espaço em disco serão liberados.
      Você quer continuar [S/n]? ^C

      O resto o Grub se encarrega de corrigir automaticamente, mas se quiser digite:

      # update-grub

      Curtir

  3. elvis disse:

    Bom cara um ultima pergunta sobre esse tema, Após instalar o kernel liquorix pelo seu tutorial meu virtualbox 4.2 esta dando um error. E aparece esta mensagem, quando vou execultar a Vm.

    Kernel driver not installed (rc=-1908)

    The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

    ‘/etc/init.d/vboxdrv setup’

    as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

    Tenho que reinstalar o virtualbox? Agradeço mais uma vez, e este seu blog é um dos melhores em Gnu/Linux.

    Curtir

    1. edps disse:

      Você tem que instalar:

      # apt-get install dkms build-essential linux-headers-liquorix-$arch

      * onde $arch = 686 ou amd64 e em seguida executar:

      # /etc/init.d/vboxdrv setup
      # adduser SEU_USUARIO vboxsf

      e na sua instalação real (não é a do VirtualBox):

      # adduser SEU_USUARIO vboxusers

      Curtir

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s