WINE 1.5.5 no Debian Wheezy


E dessa vez sem compilações ou feitiçarias veremos aqui um facílimo método de instalação de versão mais atualizada do WINE no Debian.

Antes de mais nada, caso queira compilar, comece pela instalação das dependências…
# apt-get update
# apt-get install bison build-essential ccache checkinstall esound-common flex fontforge gcc gir1.2-gst-plugins-base-0.10 git-core libasound2-dev libaudio-dev libaudiofile-dev libavahi-client-dev libavahi-common-dev libc6-dev libcapi20-3 libcapi20-dev libcups2-dev libdbus-1-dev libelfg0 libesd0 libesd0-dev libexif-dev libexpat1-dev libfontconfig1-dev libfontforge1 libfreetype6-dev libgcrypt11-dev libgdraw4 libgif-dev libgl1-mesa-dev libgl1-nvidia-glx libglib2.0-dev libglu1-mesa-dev libgnutls-dev libgpg-error-dev libgphoto2-2-dev libgsm1-dev libgstreamer-plugins-base0.10-dev libgstreamer0.10-dev libhal-dev libhal-storage-dev libice-dev libieee1284-3-dev libjack-dev libjack0 libjbig-dev libjpeg8-dev libjs-jquery liblcms1-dev libldap2-dev libltdl-dev libmad0 libmad0-dev libmpg123-dev libncurses5-dev libogg-dev libopenal-dev libopenal1 libpng12-dev libpopt-dev libsane-dev libsm-dev libspiro0 libssl-dev libtasn1-3-dev libtiff4-dev libtiffxx0c2 libuninameslist0 libusb-dev libv4l-dev libvorbis-dev libvorbisfile3 libx11-dev libxau-dev libxcomposite-dev libxcursor-dev libxdmcp-dev libxext-dev libxfixes-dev libxft-dev libxi-dev libxinerama-dev libxml2-dev libxmu-dev libxmu-headers libxrandr-dev libxrender-dev libxslt1-dev libxt-dev libxv-dev libxxf86vm-dev linux-libc-dev m4 make mesa-common-dev odbcinst odbcinst1debian2 prelink unixodbc unixodbc-dev x11proto-composite-dev x11proto-core-dev x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev x11proto-randr-dev x11proto-video-dev x11proto-xext-dev x11proto-xf86vidmode-dev x11proto-xinerama-dev xtrans-dev zlib1g-dev

Passe para o download do source do programa…

$ wget http://mirrors.ibiblio.org/wine/source/1.6/wine-1.6-rc4.tar.bz2

Sua descompactação…

$ tar -jxvf wine-1.6-rc4.tar.bz2

Entre no diretório de trabalho e inicie a compilação…

$ cd wine-1.6-rc4
$ ./configure --prefix=/usr --sysconfdir=/etc
$ make

Dependendo de sua máquina vai demorar um bom tempo! vá catar o que fazer enquanto rola todo o processo!

Após um longo tempo, instale com…

$ sudo make install

Ou crie um .deb com o checkinstall e instale com o dpkg…

$ sudo checkinstall -D --install=no
$ sudo dpkg -i wine*.deb
$ sudo apt-get -f install

O método fácil.

Execute os comandos abaixo (substituindo a arquitetura i386 por amd64 se for o caso):

$ mkdir wine-unstable
$ cd wine-unstable

Baixe os pacotes .deb (substituindo nos links a arquitetura i386 por amd64 se for o caso):

$ wget http://dev.carbon-project.org/debian/wine-unstable/libwine-alsa-unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/libwine-bin-unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/libwine-cms-unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/libwine-dev-unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/libwine-gl-unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/libwine-gphoto2-$ wget unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/libwine-ldap-unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/libwine-openal-unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/libwine-oss-unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/libwine-print-unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/libwine-sane-unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/libwine-unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/wine-bin-unstable_1.5.5-0.1_i386.deb
$ wget http://dev.carbon-project.org/debian/wine-unstable/wine-unstable_1.5.5-0.1_i386.deb

* se usar um Debian i686 como eu, basta clicar sobre cada link acima que você será redirecionado para o download do pacote.

Em caso de erros, novas versões podem ser obtidas no endereço abaixo:

http://dev.carbon-project.org/debian/wine-unstable/

Instale todos os pacotes com:

$ sudo dpkg -i *.deb
$ sudo apt-get -f install
$ cd ..
$ rm -rfv wine-unstable

Se quiser instale o WineTricks:

$ sudo apt-get install winetricks

E abra o configurador do WINE (que pedirá a instalação do pacote Gecko):

$ winecfg

Este slideshow necessita de JavaScript.

E só!

Anúncios
WINE 1.5.5 no Debian Wheezy

22 comentários sobre “WINE 1.5.5 no Debian Wheezy

  1. Barichello disse:

    Sou novo do Linux desculpe minha ignorancia :/ mas segui os passos não instalou

    dpkg: acerca de libwine-unstable_1.5.5-0.1_amd64.deb contendo libwine-unstable, problema de pre-dependência:
    libwine-unstable pré-depende de libc6-i386 (>= 2.9-18)

    dpkg: erro ao processar libwine-unstable_1.5.5-0.1_amd64.deb (–install):
    problema de pré-dependência – libwine-unstable não será instalado
    A seleccionar pacote anteriormente não seleccionado wine-bin-unstable.
    Desempacotando wine-bin-unstable (de wine-bin-unstable_1.5.5-0.1_amd64.deb) …
    A seleccionar pacote anteriormente não seleccionado wine-unstable.
    Desempacotando wine-unstable (de wine-unstable_1.5.5-0.1_amd64.deb) …
    dpkg: problemas com dependências impedem a configuração de libwine-alsa-unstable:
    libwine-alsa-unstable depende de lib32asound2 (>> 1.0.25); porém:
    Pacote lib32asound2 não está instalado.
    libwine-alsa-unstable depende de libc6-i386 (>= 2.1.3); porém:
    Pacote libc6-i386 não está instalado.
    libwine-alsa-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.

    dpkg: erro ao processar libwine-alsa-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de libwine-bin-unstable:
    libwine-bin-unstable depende de libc6-i386 (>= 2.7); porém:
    Pacote libc6-i386 não está instalado.
    libwine-bin-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.

    dpkg: erro ao processar libwine-bin-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de libwine-capi-unstable:
    libwine-capi-unstable depende de libc6-i386 (>= 2.1.3); porém:
    Pacote libc6-i386 não está instalado.
    libwine-capi-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.

    dpkg: erro ao processar libwine-capi-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de libwine-cms-unstable:
    libwine-cms-unstable depende de ia32-libs (>= 20120102); porém:
    Pacote ia32-libs não está instalado.
    libwine-cms-unstable depende de libc6-i386 (>= 2.1.3); porém:
    Pacote libc6-i386 não está instalado.
    libwine-cms-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.

    dpkg: erro ao processar libwine-cms-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de libwine-dbg-unstable:
    libwine-dbg-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.

    dpkg: erro ao processar libwine-dbg-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de libwine-dev-unstable:
    libwine-dev-unstable depende de libc6-i386 (>= 2.11); porém:
    Pacote libc6-i386 não está instalado.
    libwine-dev-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.
    libwine-dev-unstable depende de libc6-dev-i386; porém:
    Pacote libc6-dev-i386 não está instalado.

    dpkg: erro ao processar libwine-dev-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de libwine-gl-unstable:
    libwine-gl-unstable depende de ia32-libs (>= 20120102); porém:
    Pacote ia32-libs não está instalado.
    libwine-gl-unstable depende de libc6-i386 (>= 2.7); porém:
    Pacote libc6-i386 não está instalado.
    libwine-gl-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.

    dpkg: erro ao processar libwine-gl-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de libwine-gphoto2-unstable:
    libwine-gphoto2-unstable depende de ia32-libs (>= 20120102); porém:
    Pacote ia32-libs não está instalado.
    libwine-gphoto2-unstable depende de libc6-i386 (>= 2.1.3); porém:
    Pacote libc6-i386 não está instalado.
    libwine-gphoto2-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.

    dpkg: erro ao processar libwine-gphoto2-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de libwine-ldap-unstable:
    libwine-ldap-unstable depende de ia32-libs (>= 20120102); porém:
    Pacote ia32-libs não está instalado.
    libwine-ldap-unstable depende de libc6-i386 (>= 2.3); porém:
    Pacote libc6-i386 não está instalado.
    libwine-ldap-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.

    dpkg: erro ao processar libwine-ldap-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de libwine-openal-unstable:
    libwine-openal-unstable depende de ia32-libs (>= 20120102); porém:
    Pacote ia32-libs não está instalado.
    libwine-openal-unstable depende de libc6-i386 (>= 2.1.3); porém:
    Pacote libc6-i386 não está instalado.
    libwine-openal-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.

    dpkg: erro ao processar libwine-openal-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de libwine-oss-unstable:
    libwine-oss-unstable depende de libc6-i386 (>= 2.1.3); porém:
    Pacote libc6-i386 não está instalado.
    libwine-oss-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.
    libwine-oss-unstable depende de oss-compat; porém:
    Pacote oss-compat não está instalado.

    dpkg: erro ao processar libwine-oss-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de libwine-print-unstable:
    libwine-print-unstable depende de libc6-i386 (>= 2.3); porém:
    Pacote libc6-i386 não está instalado.
    libwine-print-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.

    dpkg: erro ao processar libwine-print-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de libwine-sane-unstable:
    libwine-sane-unstable depende de libc6-i386 (>= 2.1.3); porém:
    Pacote libc6-i386 não está instalado.
    libwine-sane-unstable depende de libwine-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-unstable não está instalado.

    dpkg: erro ao processar libwine-sane-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de wine-bin-unstable:
    wine-bin-unstable depende de libwine-bin-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-bin-unstable não está configurado ainda.

    dpkg: erro ao processar wine-bin-unstable (–install):
    problemas de dependência – deixando desconfigurado
    dpkg: problemas com dependências impedem a configuração de wine-unstable:
    wine-unstable depende de wine-bin-unstable (= 1.5.5-0.1); porém:
    Pacote wine-bin-unstable não está configurado ainda.
    wine-unstable depende de libwine-alsa-unstable (= 1.5.5-0.1) | libwine-oss-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-alsa-unstable não está configurado ainda.
    Pacote libwine-oss-unstable não está configurado ainda.
    wine-unstable depende de libwine-gl-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-gl-unstable não está configurado ainda.
    wine-unstable depende de libwine-print-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-print-unstable não está configurado ainda.
    wine-unstable depende de libwine-sane-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-sane-unstable não está configurado ainda.
    wine-unstable depende de libwine-cms-unstable (= 1.5.5-0.1); porém:
    Pacote libwine-cms-unstable não está configurado ainda.
    wine-unstable depende de libwine-gphoto2-unstable (= 1.5.5-0.1); porém:

    dpkg: erro ao processar wine-unstable (–install):
    problemas de dependência – deixando desconfigurado
    Processando gatilhos para man-db …
    Processando gatilhos para mime-support …
    Processando gatilhos para desktop-file-utils …
    Processando gatilhos para gnome-menus …
    Erros foram encontrados durante o processamento de:
    libwine-unstable_1.5.5-0.1_amd64.deb
    libwine-alsa-unstable
    libwine-bin-unstable
    libwine-capi-unstable
    libwine-cms-unstable
    libwine-dbg-unstable
    libwine-dev-unstable
    libwine-gl-unstable
    libwine-gphoto2-unstable
    libwine-ldap-unstable
    libwine-openal-unstable
    libwine-oss-unstable
    libwine-print-unstable
    libwine-sane-unstable
    wine-bin-unstable
    wine-unstable

    Curtir

    1. edps disse:

      Aparentemente por causa da libc6-i386 e de outros pacotes antes de tentar instalar o WINE, seu sistema precisa de:

      # apt-get update
      # apt-get dist-upgrade

      Antes de seguir os passos acima resolva as dependências com:

      # apt-get -f install

      Isso provavelmente removerá todos os pacotes do WINE, depiis disso você segue com os dois comandos lá do início, instala op WINE com:

      # dpkg -i *.deb
      # apt-get -f install

      E se seu sistema for amd64, veja isto:

      http://gnutwoall.wordpress.com/2013/07/19/multiarch-suporte-no-debian/

      Curtir

    1. edps disse:

      Obrigado e que bom que resolveu.

      Viu só Às vezes nós mesmos podemos solucionar nossos problemas, uma boa idéia é participar de fóruns como o VOL, pois isso aqui é um blog que durante o dia me limito a autorizar os comentários, somente à noite é que eu os respondo e enquanto isso alguns ficam nessa agonia de querer resolver as coisas, seja com uma resposta que eu dê ou outros.

      Em fóruns tudo é mais rápido.

      Curtir

  2. Barichello disse:

    Eu participo sim do VOL é muito show, mas o jeito que explica aqui é muito didático e acho mais fácil :). No meu pc de mesa a wine está funcionando perfeitamente agora instalei no meu notbook porém depois de instalar tudo direitinho aparece esse erro
    #root@Barik:/home/barichello# winecfg
    p11-kit: couldn’t load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: Arquivo ou diretório não encontrado

    essa está difícil de achar solução… Obrigado Abraço.

    Curtir

  3. Barichello disse:

    Ja instalei e está na versão mais atualizada
    #Lendo informação de estado… Pronto
    gnome-keyring já é a versão mais nova.
    0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.#

    ai no Bug reports tem isso:
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=686843
    só que não intendi como converter o pacote para multiarch
    “The gnome-keyring package will need to be converted to multiarch to fix that.”
    saberia me explicar como ?

    Curtir

      1. Barichello disse:

        Nesse caso eu uso sistema 64bits amd64, mas fiz a instalação da architecture i386 como no seu tutorial pedia pra poder instalar a Wine ficou com i386 instalei tudo ok, porém acabei de dar um dpkg –print-architecture e está novamente amd64.
        Seria a solução isso ?
        # dpkg –add-architecture i386
        # apt-get update
        Mas eu já tinha instalado ela ai estou confuso.

        Curtir

      2. edps disse:

        Se o seu sistema era amd64 ele continuará sendo mesmo que você adicione o multi-arch, não adianta adionar o i386 e pensar que o sistema passe a ser um (a menos que você reinstale todos os pacotes amd64 como i386) o que dará um trabalho desgraçado!

        Vejo vantagem do multi-arch principalmente em Debian amd64 por causa do Flash, WINE e outros e só!

        Eu num Debian i686 só o utilizo porque acabei instalando o kernel amd64 (que nem uso).

        Curtir

  4. Barichello disse:

    Tentei muita coisa já e não tive solução ainda… porém testei e os programas .exe estão instalando, não sei exatamente como o erro afeta o uso da Wine, mas por enquanto está funcionando o básico que eu precisava. Agradeço muito a ajuda, obrigado pelas explicações pesquisando essas coisas aprendi muito mais sobre linux.

    Curtir

  5. jumesyn disse:

    seu edps, sabe como resolver esse problema?:

    checking for X… no
    configure: error: X 32-bit development files not found. Wine will be built
    without X support, which probably isn’t what you want. You will need
    to install 32-bit development packages of Xlib/Xfree86 at the very least.
    Use the –without-x option if you really want this.

    Curtir

  6. Ola Amigo! Estou há tempos tentando instalar o Wine em meu Debian Wheezy 4.6.2-12 – versão 3.4.9 i686 sem sucesso. Agora fui até o Passo 2 em ingressar no Diretorio para compilar – mas no Passo 3 => $ make => Apareceu MSG: “make: *** Nenhum alvo indicado e nenhum arquivo make encontrado. Pare.” O que devo fazer? É imprescindivel que faça com User Comum e não root? – Sou novato e agradeço se puder me ajudar! ABS
    gaDS

    Curtir

    1. edps disse:

      Dê uma lida novamente pois atualizei a dica acrescentando novas coisas e inclusive mais pacotes -dev, agora a lista de -devs está exatamente igual à dica:

      http://gnutwoall.wordpress.com/2012/08/25/wine-1-5-11-no-debian-squeeze/

      Muito provavelmente você não conseguiu rodar o make por causa de erros (falta de pacotes) na hora do ./configure, reveja os novos passos, exclua a pasta que utilizou anteriormente, descompacte de novo e recomece.

      Agora, tanto essa quanto a dica anterior tem os mesmos passos.

      Curtir

  7. Prezado edps – Bom Dia! – Tenho lido (e aprendido um pouco creio) muitas de suas Orientações. Agradeço em Nome de Todos. No entanto – creio que seja talvez um “caso special” – Pois desde 2000 (exatamente) Instalo Linux em meus PC’s – sem no entanto JAMAIS ter conseguido usa-lo (eficientemente) qual o Windows – que sempre desejei não depender. Já instalei Kurumin / Mandriva / e outras mais – comprando os CD’s de Instalação.
    .
    Agora comprei este PC – já com Debian Wheezy 4.6.2-12 Versão 3.4.9 i686 no inicio do ano e no entanto quase um ano após – sequer consegui instalar (eficientemente) um UNICO programa. Assim fica muito difícil usar Linux – sem poder criar os Filmes / Usar Outlook com scripts / Instalar outros Programas que ainda que “crackeados” em Windows (que todos fazem) e permitia desfrutar dos mesmos – o que infelizmente não ocorre com SO’s Linux.
    .
    De modo geral TODOS – procuram ajudar – MAS – segue-se as instruções (comandos) passados e RARAMENTE funciona corretamente ou então arruma uma coisa e “desarruma” outras. Idem quanto as sources.list (tenho procurado seguir as criadas pelo Amigo) que deixam de atender certos requisitos.
    .
    Por exemplo – veio instalado (tudo funcionando) Skype / Firefox / Amarok) e agora: Skype só ficou um icone (em branco no Desktop) = Não funciona – e nem consegui re-instala-lo e é primordial – pois fiquei privado de falar com minhas 6 filhas que moram longe). Amarok (não é essencial – pois posso usar outros para sons) / Firefox – me bloqueou o acesso ao Internet banking da CEF – que no meu caso “minimo-assalariado-aposentado” – nem posso saber via Net de minha conta mais) – Wine – que é o motivo de minha consulta – JAMAIS consegui instala-lo – assim como JAMAIS consegui instalar Comandos Gráficos para facilitar minha vida.
    .
    Perdoe-me pelo “desabafo”. Ora estou com 67 years old – Mas desde os 55 tento usar Linux. Em Windows sou considerado “usuário avançado” (mesmo me considerando um “analfabétiko informátiko) – pois crio Videos (tenho mais de 500 na net / crio DVDs com Scripts envolvendo sons – movimentos – edição de imagens etc – além de milhares de PPTs PPS Educativos para Universidades (antes dos 6 anos de desemprego atuais).

    APLAUSOS sinceros pela sua socialização de Conhecimentos e novamente – perdoe-me se o aborreci com tudo o que ora (d)escrevi. Abraços – Prof. JC. Avelar – gaDs!

    — — -> Log resposta após o Passo 2 Acima:
    Alguns pacotes não puderam ser instalados. Isto pode significar que você solicitou uma situação impossível ou, se você está usando a distribuição instável, que alguns pacotes requeridos não foram criados ainda ou foram retirados da “Incoming”. A informação a seguir pode ajudar a resolver a situação:

    Os pacotes a seguir têm dependências desencontradas:
    libcups2-dev : Depende: libcups2 (= 1.5.3-5) mas 1.5.3-5+deb7u1 está para ser instalado
    E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.
    oem@oem-linux:~$
    … … .
    *** Tenho Diversos Posts no Fórum do VOL (em iniciantes) que parece que morrerei sendo – a Maioria com respostas que no entanto não resolveram as Dificuldades Objeto dos Tópicos abordados.

    Curtir

    1. edps disse:

      Taí, uma coisa que deve ter em mente é que um PC comprado e que vem com uma versão (derivação) de uma distribuição Linux não é propriamente uma cópia exata dela, sempre ocorrem problemas do tipo o que você está sofrendo, seja nesse seu OEM (que vi pelo log do VOL), seja no Satux, Fenix ou outro.

      O que você poderia tentar fazer é baixar o DVD de instalação do Debian (ou o CD com seu ambiente preferido), gravá-lo em CD|DVD, instalá-lo e após a instalação adicionar apenas mais uma linha em seu sources.list, que ficaria basicamente assim:

      deb http://ftp.debian.org/debian/ wheezy main
      deb http://security.debian.org/ wheezy/updates
      deb http://ftp.debian.org/debian/ wheezy-updates main

      Necessitando de instalar pacotes não-livres, como o plugin Flash, drievrs de vídeo, etc, deixaria assim:

      deb http://ftp.debian.org/debian/ wheezy main contrib non-free
      deb http://security.debian.org/ wheezy/updates main contrib non-free
      deb http://ftp.debian.org/debian/ wheezy-updates main contrib non-free

      Se não tem conhecimento avançado em Linux esqueça a tentativa de usar esse WIne aqui proposto, pois aqui o negócio é baixar os sources, compilar e empacotar, ou seja, tarefas não comuns a um usuário normal. ALém disso, existe o fato desses problemas de dependências, que geralmente num Debian bem configurado resolve-se com:

      # apt-get update
      # apt-get upgrade
      # apt-get dist-upgrade

      Acostume-se! você SEMPRE deve rodar um apt-get update antes de tentar instalar qualquer coisa, seja com:

      # apt-get install pacote

      ou com:

      # dpkg -i pacote.deb
      # apt-get -f install

      Baixar os CDs ou DVDs.

      Em CDs, o 1º CD é sempre com Gnome, mas existem outras mídias com KDE, XFCE, LXDE e NetInstall.

      Se entende do protocolo torrents, baixe a mídia desejada do link abaixo (se vai usar Skype dê preferência pela arquitetura i386):

      http://www.debian.org/CD/torrent-cd/

      * no campo ( Torrents oficiais para a distribuição estável (stable) ), escolha entre CD ou DVD e a arquitetura a ser usada.

      Agora, se não entende de torrents, baixe do modo tradicional (pelo navegador):

      http://www.debian.org/CD/http-ftp/

      Ou copie o link com o mouse e baixe pelo wget (exemplo de como baixar a mídia em CD com Gnome):

      $ wget http://cdimage.debian.org/debian-cd/7.1.0/i386/iso-cd/MD5SUMS
      $ wget -c -T0 http://cdimage.debian.org/debian-cd/7.1.0/i386/iso-cd/debian-7.1.0-i386-CD-1.iso
      $ md5sum -c MD5SUMS

      * no campo ( Imagens oficiais de CD/DVD da distribuição estável (stable) ), escolha entre CD ou DVD e a arquitetura a ser usada.

      É necessário dizer que desse modo, ao clicar num dos CDs ou DVD, também é necessário baixar da mesma pasta o arquivo MD5SUMS, pois ao final você deve conferir a integridade da mídia com:

      $ md5sum -c MD5SUMS

      Se não aparecer problemas você verá a mensagem SUCESSO, do contrário, verá FALHOU.

      Curtir

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

w

Conectando a %s