Instalação do FreshPlayer no Debian e derivados (outro modo)


Tempos atrás demonstrei como instalar o Fresh Player (uma alternativa ao Pipelight e ao Flash nativo) em seu Debian baixando o código-fonte via git e compilando, dessa vez veremos como instalá-lo via debian package do repositório de testes do MEPIS.

Instalação.

i686.

$ wget http://main.mepis-deb.org/mepiscr/testrepo/pool/test/f/freshplayerplugin/freshplayerplugin_0.2.2+git20150213-1mcr120+1_i386.deb
$ sudo dpkg -i freshplayerplugin_0.2.2+git20150213-1mcr120+1_i386.deb
$ sudo apt-get -f install

amd64.

$ wget http://main.mepis-deb.org/mepiscr/testrepo/pool/test/f/freshplayerplugin/freshplayerplugin_0.2.2+git20150213-1mcr120+1_amd64.deb
$ sudo dpkg -i freshplayerplugin_0.2.2+git20150213-1mcr120+1_amd64.deb
$ sudo apt-get -f install

E pronto!, mas se tens o pacote flashplugin-nonfree, aproveite e desinstale-o:

$ sudo apt-get --purge remove flashplugin-nonfree

Feito isto, abra seu navegador Iceweasel|Firefox, Opera 12.16 e verifique se o plugin está ativo:

Este slideshow necessita de JavaScript.

Solução de problema.

Andei reparando que tanto no Debian Wheezy i686 como no Debian Jessie amd64 este pacote ficou como órfão, então para que o mesmo não seja removido, convém travá-lo (como root):

# echo “freshplayerplugin hold”|dpkg –set-selections

E para atualizá-lo no futuro (também como root) execute:

# echo “freshplayerplugin install”|dpkg –set-selections
# apt-get update

E procure seja no repositório do MEPIS ou da PPA do WebUpd8 por uma versão mais nova.

Observação.

Não fosse por problemas de dependências que afetam o Debian Wheezy, seria possível instalar uma versão ainda mais recente do FreshPlayer, direto da PPa do WebUpd8, se esta não for sua release, provavelmente será possível instalar o pacote da versão 0.2.3+git20150216, segue o link aos interessados:

FreshPlayer @ WebUpd8 PPA

IntÉ!

Anúncios
Instalação do FreshPlayer no Debian e derivados (outro modo)

8 comentários sobre “Instalação do FreshPlayer no Debian e derivados (outro modo)

    1. edps disse:

      rsrs, acabei de testar no Jessie e o que foi demonstrado nos exemplos tambem funcionam, ams os da PPA do Ubuntu não, também por causa de dependências.

      Verei o que posso fazer no caso (se dá para modificar as versões no arquivo control), empacotar e o mesmo funcionar.

      Curtir

  1. Testado e aprovado com louvor!
    Ficou um espetáculo no meu Icewaesel 35.01, aparece a versão 16 do flash, leu youtube, terra, uol…

    Só repetir o procedimento quando precisar atualizar?

    Estou meio sumido pq passei na Fatec em Análise de Sistemas, vamos ver no que dá com quase 4.0 se dá para tocar.

    Abraço,

    Obrigado pela dica

    Curtir

    1. edps disse:

      Ok muchacho, mas como nada são flores… andei reparando que esse pacote ficou como órfão em meus sistemas, então para que o mesmo não seja removido, seja ao executar um apt-get autoremove –purge ou por outro motivo, trave-o assim (como root):

      # echo “freshplayerplugin hold”|dpkg –set-selections

      Quando quiser atualizá-lo, destrave-o:

      # echo “freshplayerplugin install”|dpkg –set-selections

      Vou acrescentar essa nota à dica.

      Curtir

      1. Deu um bug aqui:
        root@hotpc:/home/brainiac# echo “freshplayerplugin hold”|dpkg –set-selections
        dpkg: erro: necessário uma opção de ação

        Escreva dpkg –help para ajuda sobre instalar e desinstalar pacotes [*];
        Utilize `dselect’ ou `aptitude’ para gestão de pacotes amigável;
        Escreva dpkg -Dhelp para uma lista de valores de flags de debug do dpkg;
        Escreva dpkg –force-help para uma lista de opções para forçar operações;
        Escreva dpkg-deb –help para ajuda sobre manipular ficheiros *.deb;

        Opções marcadas com [*] produzem muita saída de texto – utilize pipes com `less’ ou `more’ !

        Curtir

      2. edps disse:

        Provavelmente o erro está nos 2 traços (que não aparecem no WordPress, ou seja, aparecem como um travessão , o comando é:

        #echo “freshplayerplugin hold”|dpkg (dois-traços-aqui)set-selections

        Curtir

  2. Olá amigo o primeiro link não está mais disponível:
    root@hotpc:/home/brainiac# wget http://main.mepis-deb.org/mepiscr/testrepo/pool/test/f/freshplayerplugin/freshplayerplugin_0.2.2+git20150213-1mcr120+1_i386.deb
    –2015-07-28 22:25:57– http://main.mepis-deb.org/mepiscr/testrepo/pool/test/f/freshplayerplugin/freshplayerplugin_0.2.2+git20150213-1mcr120+1_i386.deb
    Resolvendo main.mepis-deb.org (main.mepis-deb.org)… 70.40.214.183
    Conectando-se a main.mepis-deb.org (main.mepis-deb.org)|70.40.214.183|:80… conectado.
    A requisição HTTP foi enviada, aguardando resposta… 404 Not Found
    2015-07-28 22:25:58 ERRO 404: Not Found.

    mas consegui baixar no:
    root@hotpc:/home/brainiac# wget https://launchpad.net/~nilarimogard/+archive/ubuntu/test/+build/7624276
    –2015-07-28 22:28:10– https://launchpad.net/~nilarimogard/+archive/ubuntu/test/+build/7624276
    Resolvendo launchpad.net (launchpad.net)… 91.189.89.223, 91.189.89.222
    Conectando-se a launchpad.net (launchpad.net)|91.189.89.223|:443… conectado.
    A requisição HTTP foi enviada, aguardando resposta… 200 OK
    Tamanho: 15407 (15K) [text/html]
    Salvando em: “7624276”

    100%[======================================>] 15.407 48,1K/s em 0,3s

    2015-07-28 22:28:16 (48,1 KB/s) – “7624276” salvo [15407/15407]

    Curtir

  3. Basta você subir um nível do diretório do site do MEPIS, assim:

    http://main.mepis-deb.org/mepiscr/testrepo/pool/test/f/freshplayerplugin/

    Veja se consegue instalar a versão 0.2.4+git20150610-1mcr120+1:

    http://main.mepis-deb.org/mepiscr/testrepo/pool/test/f/freshplayerplugin/freshplayerplugin_0.2.4+git20150610-1mcr120+1_i386.deb

    ou

    http://main.mepis-deb.org/mepiscr/testrepo/pool/test/f/freshplayerplugin/freshplayerplugin_0.2.4+git20150610-1mcr120+1_amd64.deb

    Tem outras versões, mas não sabendo qual é o seu Debian, provavelmente tentar instalar a versão mais baixa talvez funcione.

    Curtir

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s