How-To :: Debian Jessie Backports


E já existem updates no Backports para o Debian Jessie! então vamos ver como configurá-lo afim de receber pacotes mais novos em seu Debian Stable.

apt.conf.

Com o seu editor de textos preferido abra (ou crie) o arquivo /etc/apt/apt.conf, colando o seguinte:

APT::Default-Release "jessie-backports";
APT::Cache-Limit "300000000";
APT::Get::AllowwUnauthenticated "0";
APT::Get::Purge "1";
APT::Get::AutomaticRemove "1";
APT::Get::HideAutoRemove "0";
APT::Install-Reccomends "0";
APT::Install-Suggests "0";
Aptitude::Recommends-Important "1";
Acquire::Queue-Mode "host";
Acquire::Languages "none";

Antes de começar explico que para desabilitar qualquer uma das opções demonstradas acima basta inserir // antes da mesma, como em //APT::Default-Release “jessie-backports”;, que faria com que seu APT voltasse ao seu normal, digo, entender a release padrão como jessie somente.

Vejo muitas vantagens em usar o apt.conf a primeira e principal não me diz respeito, mas sim aos aventureiros que cismam em inserir os repos Testing/Unstable/Experimental na release Stable, assim, se a release está definida, não tem como ocorrer uma catástrofe (atém tem), mas eles teriam que rodar por exemplo um:

# apt-get -t testing|unstable|experimental dist-upgrade

O mesmo vale para o uso de algumas PPAs do Ubuntu. Quando digo PPAs do Ubuntu me refiro aquelas que contenham muitos pacotes, não um simples pogo audio player ou de pacotes de temas.

Explicando…

APT::Default-Release “jessie-backports”; – define a release padrão para o Debian Jessie Backports, assim você não precisará rodar por exemplo o comando: apt-get -t jessie-backports dist-upgrade e sim um simples apt-get dist-upgrade ou como eu que uso um alias para isso, um singelo dupgrade, assim até a minha vovózinha usaria Debian!

APT::Cache-Limit “300000000”; – previne o erro chato “E: Dynamic MMap ran out of room. Please increase the size of APT::Cache-Limit”, aumentando o tamanho do cache. Você pode até acrescentar mais um “0” aí, mas não vejo necessidade, aqui sempre funcionou desta forma.

APT::Get::AllowwUnauthenticated “0”; – não permite a instalação de pacotes não assinados digitalmente, você até poderá instalá-los teclado y ou s algumas vezes, mas será perguntado antes.

Uma forma de burlar essa opção é usar a opção –allow-unauthenticated no apt-get, como em:

# apt-get --allow-unauthenticated install pacote-de-outro-mundo.deb

APT::Get::Purge “1”; – automaticamente remove as configurações do programa assim que o mesmo é removido, para desativar (e não vejo o porque disto) altere o valor para “0”.

APT::Get::AutomaticRemove “1”; – remove automaticamente os pacotes órfãos, se não compreende bem o funcionamento de um sistema Debian, é recomendável deixá-la como “0”, assim ao remover programas o APT dirá que os pacotes não são mais necessários e podem ser removidos, daí você pode executar isto para tal:

# apt-get autoremove

ou

# apt-get autoremove --purge

APT::Install-Reccomends “0”; – aqui vai do gosto do freguês, se quer ter um sistema mais enxuto, mas isso não quer dizer mais completo, deixe-a como “0” e ao instalar um pacote via modo CLI, observe os pacotes presentes no campo “pacotes recomendados”, pois pode ocorrer de alguns pacotes serem realmente necessários para um bom funcionamento do programa instalado.

Deixá-la como “1” fará com o que APT trabalhe com o padrão Debian.

APT::Install-Suggests “0”; – em geral esta opção deve ficar exatamente assim, pois são pacotes que não agregam utilizade alguma ao pacote instalado, mas observar o campo “pacotes sugeridos” poderá levá-lo ao conhecimento de outras ferramentas equivalentes ao pacote instalado.

Aptitude::Recommends-Important “1”; – sendo o aptitude chato por si só, convém deixar essa opção assim.

Acquire::Queue-Mode “host”; – define a forma como o APT trabalhará paralelizando as ligações de saída, existem duas alternativas para essa opção, a “host” que abre uma uma ligação por máquina destino e a “access” que abre uma ligação por tipo de URI.

Acquire::Languages “none”; – deixada como “none” define que nenhum pacote de tradução será baixado exceto o nosso pt_BR. Como alternativa, você pode usar “environment”, definindo os pacotes de tradução desejados, como em:

Acquire::Languages { "environment"; "pt_BR"; "en"; "none"; "de"; "esp"; "fr"; };

Exemplo:

[4306:4296 0:58] 01:24:58 Ter Mai 12 [edps@debian: +1] ~ 
(1:58)$ update
Ign http://dl.google.com stable InRelease
Atingido http://security.debian.org jessie/updates InRelease                               
Atingido http://www.deb-multimedia.org jessie InRelease                                    
Atingido http://deb.opera.com stable InRelease                                             
Ign http://repo.vivaldi.com stable InRelease                                               
Atingido http://dl.google.com stable Release.gpg                                           
Atingido http://security.debian.org jessie/updates/main Sources                            
Atingido http://repo.vivaldi.com stable Release.gpg                                        
Atingido http://www.deb-multimedia.org jessie/main i386 Packages                           
Atingido http://dl.google.com stable Release                                               
Atingido http://deb.opera.com stable/non-free i386 Packages                                
Atingido http://security.debian.org jessie/updates/contrib Sources                         
Atingido http://www.deb-multimedia.org jessie/non-free i386 Packages                       
Atingido http://security.debian.org jessie/updates/non-free Sources                        
Atingido http://repo.vivaldi.com stable Release                                            
Atingido http://dl.google.com stable/main i386 Packages                                    
Atingido http://security.debian.org jessie/updates/main i386 Packages                      
Atingido http://http.debian.net sid InRelease                                              
Atingido http://repo.vivaldi.com stable/main i386 Packages                                 
Atingido http://security.debian.org jessie/updates/contrib i386 Packages                   
Atingido http://http.debian.net jessie InRelease                                           
Atingido http://security.debian.org jessie/updates/non-free i386 Packages                  
Atingido http://security.debian.org jessie/updates/contrib Translation-en                  
Atingido http://security.debian.org jessie/updates/main Translation-en                     
Atingido http://http.debian.net jessie-updates InRelease                                   
Atingido http://security.debian.org jessie/updates/non-free Translation-en                 
Obter:1 http://http.debian.net jessie-backports InRelease [132 kB]                         
Obter:2 http://http.debian.net sid/main Sources/DiffIndex [7.876 B]                        
Obter:3 http://http.debian.net sid/non-free Sources/DiffIndex [7.819 B]                    
Obter:4 http://http.debian.net sid/contrib Sources/DiffIndex [7.819 B]                     
Obter:5 http://http.debian.net jessie/main Sources [7.065 kB]                              
Ign http://repo.vivaldi.com stable/main Translation-pt_BR                                  
Ign http://dl.google.com stable/main Translation-pt_BR                                     
Ign http://repo.vivaldi.com stable/main Translation-pt                                     
Ign http://repo.vivaldi.com stable/main Translation-en                                     
Ign http://dl.google.com stable/main Translation-pt                                        
Ign http://repo.vivaldi.com stable/main Translation-de                                     
Ign http://dl.google.com stable/main Translation-en                                        
Ign http://repo.vivaldi.com stable/main Translation-esp                                    
Ign http://repo.vivaldi.com stable/main Translation-fr                                     
Ign http://dl.google.com stable/main Translation-de                                        
Ign http://dl.google.com stable/main Translation-esp                                       
Atingido http://http.debian.net jessie-updates/non-free Sources                            
Ign http://deb.opera.com stable/non-free Translation-pt_BR                                 
Ign http://dl.google.com stable/main Translation-fr                                        
Obter:6 http://http.debian.net jessie-updates/main i386 Packages/DiffIndex [367 B]         
Ign http://deb.opera.com stable/non-free Translation-pt                                    
Ign http://deb.opera.com stable/non-free Translation-en                                    
Atingido http://http.debian.net jessie-updates/contrib Translation-en                      
Ign http://deb.opera.com stable/non-free Translation-de                                    
Ign http://deb.opera.com stable/non-free Translation-esp                                   
Atingido http://http.debian.net jessie-updates/non-free Translation-en                     
Ign http://deb.opera.com stable/non-free Translation-fr                                    
Obter:7 http://http.debian.net jessie-backports/main Sources/DiffIndex [2.161 B]           
Atingido http://http.debian.net jessie-backports/contrib Sources                           
Obter:8 http://http.debian.net jessie-backports/main i386 Packages/DiffIndex [4.507 B]     
Obter:9 http://http.debian.net jessie-updates/main Translation-en/DiffIndex [229 B]        
Atingido http://http.debian.net jessie-backports/non-free Sources                          
Err http://http.debian.net jessie-backports/main i386 Packages                             
  
Ign http://www.deb-multimedia.org jessie/main Translation-pt_BR                            
Ign http://www.deb-multimedia.org jessie/main Translation-pt                               
Ign http://www.deb-multimedia.org jessie/main Translation-en                               
Ign http://www.deb-multimedia.org jessie/main Translation-de                               
Ign http://www.deb-multimedia.org jessie/main Translation-esp                              
Ign http://www.deb-multimedia.org jessie/main Translation-fr                               
Ign http://www.deb-multimedia.org jessie/non-free Translation-pt_BR                        
Ign http://www.deb-multimedia.org jessie/non-free Translation-pt                           
Ign http://www.deb-multimedia.org jessie/non-free Translation-en                           
Ign http://www.deb-multimedia.org jessie/non-free Translation-de                           
Ign http://www.deb-multimedia.org jessie/non-free Translation-esp                          
Ign http://www.deb-multimedia.org jessie/non-free Translation-fr                           
Atingido http://http.debian.net jessie/non-free Sources                                    
Atingido http://http.debian.net jessie/contrib Sources                                     
Atingido http://http.debian.net jessie/main i386 Packages                                  
Atingido http://http.debian.net jessie/non-free i386 Packages                              
Atingido http://http.debian.net jessie/contrib i386 Packages                               
Atingido http://http.debian.net jessie/contrib Translation-en                              
Obter:10 http://http.debian.net jessie/main Translation-pt_BR [803 kB]                     
Obter:11 http://http.debian.net jessie/main Translation-pt [413 kB]                        
Obter:12 http://http.debian.net jessie/main Translation-en [4.585 kB]                      
Atingido http://http.debian.net jessie/main Translation-de                                 
Atingido http://http.debian.net jessie/main Translation-fr                                 
Atingido http://http.debian.net jessie/non-free Translation-en                           
Obter:13 http://http.debian.net jessie-updates/main Sources [2.471 B]                    
Obter:14 http://http.debian.net jessie-updates/contrib Sources [14 B]                      
Obter:15 http://http.debian.net jessie-backports/contrib Translation-en [14 B]             
Obter:16 http://http.debian.net jessie-backports/main Translation-en/DiffIndex [1.609 B]   
Atingido http://http.debian.net jessie-backports/non-free Translation-en                   
Obter:17 http://http.debian.net jessie-updates/contrib i386 Packages [20 B]                
Obter:18 http://http.debian.net jessie-updates/non-free i386 Packages [20 B]               
Atingido http://http.debian.net jessie-backports/contrib i386 Packages                     
Atingido http://http.debian.net jessie-backports/non-free i386 Packages                    
Err http://http.debian.net jessie-backports/main i386 Packages                             
  
Err http://http.debian.net jessie-backports/main i386 Packages                             
  
Obter:19 http://http.debian.net jessie-backports/main i386 Packages [93,5 kB]              
Baixados 13,1 MB em 1min 37s (134 kB/s)                                                    
Lendo listas de pacotes... Pronto

[4306:4296 0:58] 01:26:47 Ter Mai 12 [edps@debian: +1] ~ 
(1:58)$ 

Ao atualizar as listas de pacotes as traduções serão baixadas, mas apenas o nosso idioma e o “en” serão utilizados, as traduções “de”, “esp” e “fr” seriam utilizadas apenas se o sistema fosse em espanhol ou francês. Enfim, não vejo utilidade nisto, deixe apenas como “none” e fim de papo!

E existem muito mais opções para o apt.conf, aos interessados:

$ man apt.conf

sources.list.

E de novo com seu editor de textos preferido abra o arquivo /etc/apt/sources.list, colando o seguinte:

deb http://http.debian.net/debian/ jessie main non-free contrib
#deb-src http://http.debian.net/debian/ jessie main non-free contrib

deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://security.debian.org/ jessie/updates main contrib non-free

deb http://http.debian.net/debian/ jessie-updates main contrib non-free
#deb-src http://http.debian.net/debian/ jessie-updates main contrib non-free

deb http://http.debian.net/debian/ jessie-backports main contrib non-free
#deb-src http://http.debian.net/debian/ jessie-backports main contrib non-free

Caso queira, habilite os repos deb-src acima, removendo o sinal “#”.

Atualizando o sistema.

Se seguiu exatamente como foi demonstrado, atualize seu novo Jessie para o Jessie Backports assim:

# apt-get update
# apt-get dist-upgrade

Exemplo:

* no exemplo abaixo estou usando a opção -V que mostra as versões dos pacotes a serem atualizados e seus substitutos.

[4623:4611 0:40] 12:23:20 Ter Mai 12 [edps@debian: +1] ~ 
(1:40)$ sudo apt-get dist-upgrade -V
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Calculando atualização... Pronto
Os pacotes a seguir serão REMOVIDOS:
   libcmis-0.4-4* (0.4.1-7)
   libmwaw-0.3-3* (0.3.1-2)
Os NOVOS pacotes a seguir serão instalados:
   libpagemaker-0.0-0 (0.0.1-1)
Os pacotes a seguir serão atualizados:
   fonts-opensymbol (102.6+LibO4.3.3-2+deb8u1 => 102.6+LibO4.4.2-1~bpo8+1)
   libreoffice-base-core (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   libreoffice-calc (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   libreoffice-common (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   libreoffice-core (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   libreoffice-draw (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   libreoffice-impress (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   libreoffice-l10n-pt-br (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   libreoffice-pdfimport (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   libreoffice-style-galaxy (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   libreoffice-writer (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   libtasn1-6 (4.2-3 => 4.2-3+deb8u1)
   libtasn1-6-dev (4.2-3 => 4.2-3+deb8u1)
   libtasn1-doc (4.2-3 => 4.2-3+deb8u1)
   mercurial (3.1.2-2 => 3.1.2-2+deb8u1)
   mercurial-common (3.1.2-2 => 3.1.2-2+deb8u1)
   opera-developer (30.0.1835.6 => 31.0.1857.0)
   python-six (1.8.0-1 => 1.9.0-3~bpo8+1)
   python3-six (1.8.0-1 => 1.9.0-3~bpo8+1)
   python3-uno (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   uno-libs3 (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   ure (4.3.3-2+deb8u1 => 4.4.2-1~bpo8+1)
   vivaldi-snapshot (1.0.167.2-1 => 1.0.174.8-1)
23 pacotes atualizados, 1 pacotes novos instalados, 2 a serem removidos e 0 não atualizados.
É preciso baixar 81,1 MB/162 MB de arquivos.
Depois desta operação, 3.396 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Obter:1 http://security.debian.org/ jessie/updates/main libtasn1-doc all 4.2-3+deb8u1 [305 kB]
Obter:2 http://http.debian.net/debian/ jessie-backports/main libreoffice-draw i386 1:4.4.2-1~bpo8+1 [2.545 kB]
Obter:3 http://security.debian.org/ jessie/updates/main libtasn1-6-dev i386 4.2-3+deb8u1 [91,2 kB]
Obter:4 http://http.debian.net/debian/ jessie-backports/main uno-libs3 i386 4.4.2-1~bpo8+1 [798 kB]
Obter:5 http://security.debian.org/ jessie/updates/main libtasn1-6 i386 4.2-3+deb8u1 [50,7 kB]
Obter:6 http://security.debian.org/ jessie/updates/main mercurial i386 3.1.2-2+deb8u1 [61,5 kB]
Obter:7 http://security.debian.org/ jessie/updates/main mercurial-common all 3.1.2-2+deb8u1 [1.599 kB]
Obter:8 http://http.debian.net/debian/ jessie-backports/main ure i386 4.4.2-1~bpo8+1 [1.841 kB]
Obter:9 http://http.debian.net/debian/ jessie-backports/main libreoffice-calc i386 1:4.4.2-1~bpo8+1 [6.635 kB]
Obter:10 http://http.debian.net/debian/ jessie-backports/main libreoffice-impress i386 1:4.4.2-1~bpo8+1 [1.078 kB]
Obter:11 http://http.debian.net/debian/ jessie-backports/main python3-uno i386 1:4.4.2-1~bpo8+1 [171 kB]
Obter:12 http://http.debian.net/debian/ jessie-backports/main libreoffice-style-galaxy all 1:4.4.2-1~bpo8+1 [1.634 kB]
Obter:13 http://http.debian.net/debian/ jessie-backports/main python-six all 1.9.0-3~bpo8+1 [13,7 kB]
Obter:14 http://http.debian.net/debian/ jessie-backports/main python3-six all 1.9.0-3~bpo8+1 [13,8 kB]
Obter:15 http://http.debian.net/debian/ jessie-backports/main libreoffice-writer i386 1:4.4.2-1~bpo8+1 [7.633 kB]
Obter:16 http://http.debian.net/debian/ jessie-backports/main libreoffice-core i386 1:4.4.2-1~bpo8+1 [32,2 MB]
Obter:17 http://http.debian.net/debian/ jessie-backports/main libreoffice-common all 1:4.4.2-1~bpo8+1 [22,6 MB]
Obter:18 http://http.debian.net/debian/ jessie-backports/main libreoffice-pdfimport i386 1:4.4.2-1~bpo8+1 [285 kB]
Obter:19 http://http.debian.net/debian/ jessie-backports/main libreoffice-base-core i386 1:4.4.2-1~bpo8+1 [803 kB]
Obter:20 http://http.debian.net/debian/ jessie/main libpagemaker-0.0-0 i386 0.0.1-1 [84,9 kB]
Obter:21 http://http.debian.net/debian/ jessie-backports/main fonts-opensymbol all 2:102.6+LibO4.4.2-1~bpo8+1 [147 kB]
Obter:22 http://http.debian.net/debian/ jessie-backports/main libreoffice-l10n-pt-br all 1:4.4.2-1~bpo8+1 [483 kB]
Baixados 81,1 MB em 27min 34s (49,0 kB/s)                                      
Pré-configurando pacotes ...
(Lendo banco de dados ... 172128 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../uno-libs3_4.4.2-1~bpo8+1_i386.deb ...
A descompactar uno-libs3 (4.4.2-1~bpo8+1) sobre (4.3.3-2+deb8u1) ...
A preparar para desempacotar .../ure_4.4.2-1~bpo8+1_i386.deb ...
A descompactar ure (4.4.2-1~bpo8+1) sobre (4.3.3-2+deb8u1) ...
A preparar para desempacotar .../libreoffice-calc_1%3a4.4.2-1~bpo8+1_i386.deb ...
A descompactar libreoffice-calc (1:4.4.2-1~bpo8+1) sobre (1:4.3.3-2+deb8u1) ...
A preparar para desempacotar .../libreoffice-impress_1%3a4.4.2-1~bpo8+1_i386.deb ...
A descompactar libreoffice-impress (1:4.4.2-1~bpo8+1) sobre (1:4.3.3-2+deb8u1) ...
A preparar para desempacotar .../libreoffice-draw_1%3a4.4.2-1~bpo8+1_i386.deb ...
A descompactar libreoffice-draw (1:4.4.2-1~bpo8+1) sobre (1:4.3.3-2+deb8u1) ...
A preparar para desempacotar .../python3-uno_1%3a4.4.2-1~bpo8+1_i386.deb ...
A descompactar python3-uno (1:4.4.2-1~bpo8+1) sobre (1:4.3.3-2+deb8u1) ...
A substituir ficheiros no pacote antigo libreoffice-common (1:4.3.3-2+deb8u1) ...
A preparar para desempacotar .../libreoffice-style-galaxy_1%3a4.4.2-1~bpo8+1_all.deb ...
A descompactar libreoffice-style-galaxy (1:4.4.2-1~bpo8+1) sobre (1:4.3.3-2+deb8u1) ...
A preparar para desempacotar .../libreoffice-writer_1%3a4.4.2-1~bpo8+1_i386.deb ...
A descompactar libreoffice-writer (1:4.4.2-1~bpo8+1) sobre (1:4.3.3-2+deb8u1) ...
A preparar para desempacotar .../libreoffice-core_1%3a4.4.2-1~bpo8+1_i386.deb ...
A descompactar libreoffice-core (1:4.4.2-1~bpo8+1) sobre (1:4.3.3-2+deb8u1) ...
A preparar para desempacotar .../libreoffice-common_1%3a4.4.2-1~bpo8+1_all.deb ...
A descompactar libreoffice-common (1:4.4.2-1~bpo8+1) sobre (1:4.3.3-2+deb8u1) ...
A preparar para desempacotar .../libreoffice-pdfimport_1%3a4.4.2-1~bpo8+1_i386.deb ...
A descompactar libreoffice-pdfimport (1:4.4.2-1~bpo8+1) sobre (1:4.3.3-2+deb8u1) ...
A preparar para desempacotar .../libreoffice-base-core_1%3a4.4.2-1~bpo8+1_i386.deb ...
A descompactar libreoffice-base-core (1:4.4.2-1~bpo8+1) sobre (1:4.3.3-2+deb8u1) ...
A seleccionar pacote anteriormente não seleccionado libpagemaker-0.0-0.
A preparar para desempacotar .../libpagemaker-0.0-0_0.0.1-1_i386.deb ...
A descompactar libpagemaker-0.0-0 (0.0.1-1) ...
A preparar para desempacotar .../fonts-opensymbol_2%3a102.6+LibO4.4.2-1~bpo8+1_all.deb ...
A descompactar fonts-opensymbol (2:102.6+LibO4.4.2-1~bpo8+1) sobre (2:102.6+LibO4.3.3-2+deb8u1) ...
A processar 'triggers' para menu (2.1.47) ...
A processar 'triggers' para man-db (2.7.0.2-5) ...
A processar 'triggers' para gnome-menus (3.13.3-6) ...
A processar 'triggers' para desktop-file-utils (0.22-1) ...
A processar 'triggers' para mime-support (3.58) ...
A processar 'triggers' para gnome-icon-theme (3.12.0-1) ...
A processar 'triggers' para hicolor-icon-theme (0.13-1) ...
A processar 'triggers' para shared-mime-info (1.3-1) ...
A processar 'triggers' para fontconfig (2.11.0-6.3) ...
(Lendo banco de dados ... 172368 ficheiros e directórios actualmente instalados.)
A remover libcmis-0.4-4 (0.4.1-7) ...
A purgar os ficheiros de configuração para libcmis-0.4-4 (0.4.1-7) ...
A remover libmwaw-0.3-3 (0.3.1-2) ...
A purgar os ficheiros de configuração para libmwaw-0.3-3 (0.3.1-2) ...
A processar 'triggers' para libc-bin (2.19-18) ...
(Lendo banco de dados ... 172355 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../libtasn1-doc_4.2-3+deb8u1_all.deb ...
A descompactar libtasn1-doc (4.2-3+deb8u1) sobre (4.2-3) ...
A preparar para desempacotar .../libtasn1-6-dev_4.2-3+deb8u1_i386.deb ...
A descompactar libtasn1-6-dev (4.2-3+deb8u1) sobre (4.2-3) ...
A preparar para desempacotar .../libtasn1-6_4.2-3+deb8u1_i386.deb ...
A descompactar libtasn1-6:i386 (4.2-3+deb8u1) sobre (4.2-3) ...
A preparar para desempacotar .../vivaldi-snapshot_1.0.174.8-1_i386.deb ...
A descompactar vivaldi-snapshot (1.0.174.8-1) sobre (1.0.167.2-1) ...
A preparar para desempacotar .../libreoffice-l10n-pt-br_1%3a4.4.2-1~bpo8+1_all.deb ...
A descompactar libreoffice-l10n-pt-br (1:4.4.2-1~bpo8+1) sobre (1:4.3.3-2+deb8u1) ...
A preparar para desempacotar .../mercurial_3.1.2-2+deb8u1_i386.deb ...
A descompactar mercurial (3.1.2-2+deb8u1) sobre (3.1.2-2) ...
A preparar para desempacotar .../mercurial-common_3.1.2-2+deb8u1_all.deb ...
A descompactar mercurial-common (3.1.2-2+deb8u1) sobre (3.1.2-2) ...
A preparar para desempacotar .../opera-developer_31.0.1857.0_i386.deb ...
A descompactar opera-developer (31.0.1857.0) sobre (30.0.1835.6) ...
A preparar para desempacotar .../python-six_1.9.0-3~bpo8+1_all.deb ...
A descompactar python-six (1.9.0-3~bpo8+1) sobre (1.8.0-1) ...
A preparar para desempacotar .../python3-six_1.9.0-3~bpo8+1_all.deb ...
A descompactar python3-six (1.9.0-3~bpo8+1) sobre (1.8.0-1) ...
A processar 'triggers' para install-info (5.2.0.dfsg.1-6) ...
A processar 'triggers' para man-db (2.7.0.2-5) ...
A processar 'triggers' para menu (2.1.47) ...
A processar 'triggers' para gnome-menus (3.13.3-6) ...
A processar 'triggers' para desktop-file-utils (0.22-1) ...
A processar 'triggers' para mime-support (3.58) ...
A processar 'triggers' para hicolor-icon-theme (0.13-1) ...
Configurando uno-libs3 (4.4.2-1~bpo8+1) ...
Configurando ure (4.4.2-1~bpo8+1) ...
Configurando fonts-opensymbol (2:102.6+LibO4.4.2-1~bpo8+1) ...
Configurando libreoffice-style-galaxy (1:4.4.2-1~bpo8+1) ...
Configurando libreoffice-common (1:4.4.2-1~bpo8+1) ...
Instalando nova versão do arquivo de configuração /etc/bash_completion.d/libreoffice.sh ...
Configurando libreoffice-core (1:4.4.2-1~bpo8+1) ...
Configurando libreoffice-base-core (1:4.4.2-1~bpo8+1) ...
Configurando libreoffice-calc (1:4.4.2-1~bpo8+1) ...
Configurando libpagemaker-0.0-0 (0.0.1-1) ...
Configurando libreoffice-draw (1:4.4.2-1~bpo8+1) ...
Configurando libreoffice-impress (1:4.4.2-1~bpo8+1) ...
Configurando python3-uno (1:4.4.2-1~bpo8+1) ...
Configurando libreoffice-writer (1:4.4.2-1~bpo8+1) ...
Configurando libreoffice-pdfimport (1:4.4.2-1~bpo8+1) ...
Configurando libtasn1-doc (4.2-3+deb8u1) ...
Configurando libtasn1-6:i386 (4.2-3+deb8u1) ...
Configurando libtasn1-6-dev (4.2-3+deb8u1) ...
Configurando vivaldi-snapshot (1.0.174.8-1) ...
Configurando libreoffice-l10n-pt-br (1:4.4.2-1~bpo8+1) ...
Configurando mercurial-common (3.1.2-2+deb8u1) ...
Configurando mercurial (3.1.2-2+deb8u1) ...
Configurando opera-developer (31.0.1857.0) ...
Configurando python-six (1.9.0-3~bpo8+1) ...
Configurando python3-six (1.9.0-3~bpo8+1) ...
A processar 'triggers' para libc-bin (2.19-18) ...
A processar 'triggers' para menu (2.1.47) ...

[4623:4611 0:41] 12:54:07 Ter Mai 12 [edps@debian: +1] ~ 
(1:41)$ 

ou:

# apt-get update
# apt-get -t jessie-backports dist-upgrade

E tá lá, navegadores, softwares e LibreOffice atualizados:

Vivaldi, Opera Developer, LibreOffice e Mercurial atualizados.
Vivaldi, Opera Developer, LibreOffice e Mercurial atualizados.

Este artigo substitui o constante do artigo abaixo:

SOURCES.LIST PARA O DEBIAN JESSIE/TESTING (+ BACKPORTS)

IntÈ+!

How-To :: Debian Jessie Backports

4 comentários sobre “How-To :: Debian Jessie Backports

    1. Depende, se você optou por habilitar as seções “contrib” e “non-free” seu sources.list estará parecido com este e com o sources.list de um post anterior (fornecido pelo Debian Installer), não é o que sugeri lá:

      https://edpsblog.wordpress.com/2013/12/02/sources-list-para-o-debian-jessietesting-backports/

      Mas, para usufruir do “load-balancer : http://debian.net” que seleciona os mirror mais rápidos para você, sugiro que faça uma cópia de seu sources.list atual:

      # cp /etc/apt/sources.list /etc/apt/sources.list-debian_installer

      E sobrescreva tudo o que está nesse sources.list pelo aqui apresentado.

      Não esquecendo também de configurar|criar o /etc/apt/apt.conf para aproveitar-se do Backports.

      Curtir

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s