How-To :: instalação do Void Linux (chroot)


E hoje veremos como instalar o Void Linux num com UEFI partir de uma distribuição qualquer, aqui por meio do Slackware Current.

Por ter tido problemas com gravações de imagens .iso através com o dd, ao adquirir recentemente um SSD refiz minhas instalações do Slack, Gentoo e como terceiro sistema optei pelo Void Linux, o meio que encontrei para tê-lo instalado foi por meio de chroot, então… segue:

Particionamento e montagem.

Aqui comecei por criar o ponto de montagem /mnt/void, formatar uma partição já previamente criada /dev/sdb8, formatá-la para o sistema de arquivos btrfs, montá-la em /mnt/void e entrar no diretório de trabalho:

# mkdir -p /mnt/void
# fdisk -l | grep sdb
# mkfs.btrfs -L void /dev/sdb8
# mount /dev/sdb8 /mnt/void/
# cd /mnt/void/

Download do tarball.

Baixe o tarball do ROOTFS (para a sua arquitetura, mesma do sistema host), acho que não vai rodar se o seu sistema for x86_64 e você pegar um arquivo i686, pelo menos erros assim ocorrem no Gentoo na hora de mudar para o chroot:

# wget -c -nv -T0 https://a-hel-fi.m.voidlinux.org/live/current/void-x86_64-ROOTFS-20181111.tar.xz # se for x86_64
ou
# wget -c -nv -T0 https://a-hel-fi.m.voidlinux.org/live/current/void-i686-ROOTFS-20181111.tar.xz # se i686

Não abordarei a instalação de Void Musl, nem sei se funcionará da mesma forma, masse quiser testar segue o link para a arquitetura x86_64:

x86_64 : void-x86_64-musl-ROOTFS-20181111.tar.xz

Em seguida, descompate o arquivo baixado e copie o seu arquivo /etc/resolv.conf para a nova partição:

# tar xpf void-x86_64-ROOTFS-20181111.tar.xz --xattrs-include='*.*' --numeric-owner
# cp /etc/resolv.conf etc/resolv.conf

Ajustes e entrada no chroot.

Continue com os passos que precedem a entrada em modo chroot:

# mount --types proc /proc /mnt/void/proc
# mount --rbind /sys /mnt/void/sys
# mount --rbind /dev /mnt/void/dev
# mount --make-rslave /mnt/void/sys
# mount --make-rslave /mnt/void/dev

Se o seu sistema for UEFI como o meu, proceda com a criação do ponto de montagem /boot/efi (se não for, simplesmente ignore) e a montagem de sua partição vfat (aqui /dev/sdb2) nesse local:

# mkdir -p boot/{efi,grub}
# mount /dev/sdb2 /mnt/void/boot/efi/

Entre em modo chroot:

# chroot /mnt/void /usr/bin/bash
# export PS1="(chroot) ${PS1}"

Atualização dos pacotes.

Agora comecemos a lidar com o ótimo XBPS, atualize-o e depois aos demais pacotes (e não esqueça de instalar o nano como eu rsrs):

(chroot) bash-4.4# xbps-install -Su
(chroot) bash-4.4# xbps-install -Suv
(chroot) bash-4.4# xbps-install -S nano

Fstab.

Edite o arquivo /etc/fstab, deixando parecido com esse, atente ao sistema de arquivos usado em /:

/dev/sdb2   /boot/efi        vfat     defaults   1   0
/dev/sdb5   swap             swap     defaults   0   0
/dev/sdb8   /                btrfs    noatime,nodiratime,discard,ssd,defaults   1   1
tmpfs       /tmp             tmpfs    defaults,nosuid,nodev   0    0

Pois bem… acima vemos 3 partições, sendo que a única formatada foi a BTRFS (/dev/sdb8), isso porque as partições SWAP e BOOT são compartilhadas entre todas as distros, logo, não preciso (NEM DEVO) formatá-las, a de SWAP é o de menos. Então, se precisa de partição SWAP crie a mesma já no começo do tutorial, formate-a com mkswap /dev/sdXx e habilite-a: swapon /dev/sdXx (onde o Xx indica o nome da mesma).

Hostname, linguagem, etc…

Defina o nome da máquina em /etc/hostname, exemplo:

voidlinux

Também o arquivo /etc/hosts:

127.0.0.1 localhost.localdomain localhost
::1   localhost.localdomain localhost

No arquivo /etc/rc.conf:

HOSTNAME="voidlinux"
HARDWARECLOCK="localtime"
TIMEZONE="America/Sao_Paulo"
KEYMAP="br-abnt2"

No arquivo /etc/locale.conf:

LANG=pt_BR.UTF-8
LC_COLLATE=C

Edite o arquivo /etc/default/libc-locales e descomente o nosso pt_BR, deixando o assim:

pt_BR.UTF-8 UTF-8

Execute o comando abaixo para atualizar os locales do sistema:

(chroot) bash-4.4# xbps-reconfigure -f glibc-locales

Kerne, base-devel e Grub.

Instale o kernel e os pacotes -dev básicos:

(chroot) bash-4.4# xbps-install -S linux linux-headers base-devel

# ou para o mais atual:

(chroot) bash-4.4# xbps-install -S linux5.2 linux5.2-headers base-devel

Pesquise pelo bootloader de sua preferência, são tantas alternativas… rsrs:

# xbps-query -Rs 'bootloader'
[-] grub-2.04_1            GRand Unified Bootloader 2
[-] grub-i386-efi-2.04_1   GRand Unified Bootloader 2 - i386 EFI support
[-] grub-utils-2.04_1      GRand Unified Bootloader 2 - additional utilities
[-] grub-x86_64-efi-2.04_1 GRand Unified Bootloader 2 - x86_64 EFI support

Isto é, se seu sistema é no formato MBR escolha apenas grub, agora se como o meu for UEFI, escolha grub-x86_64-efi, após instalado atualize a lista de sistemas e grave-o em um dispositivo (aqui poderiam ainda ser /dev/sdb ou /dev/sdc):

(chroot) bash-4.4# xbps-install -S grub-x86_64-efi
(chroot) bash-4.4# grub-mkconfig -o /boot/grub/grub.cfg
(chroot) bash-4.4# grub-install /dev/sda
(chroot) bash-4.4# xbps-install -S grub-x86_64-efi
(chroot) bash-4.4# grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.19.66_1
Found initrd image: /boot/initramfs-4.19.66_1.img
Found Slackware 14.2 x86_64 (post 14.2 -current) on /dev/sdb6
Found Gentoo/Linux on /dev/sdb7
done
(chroot) bash-4.4# grub-install /dev/sda
Installing for x86_64-efi platform.
Installation finished. No error reported.

Xorg mínimo.

and now…. já está na hora de instalar o ambiente gráfico, comece por pesquisar acerca do Xorg (Wayland é o baraio meu! tô fora!):

(chroot) bash-4.4# xbps-query -Rs 'xorg'

Então, meu driver de vídeo é Intel, logo, o mínimo que eu preciso é disso:

(chroot) bash-4.4# xbps-install -S xf86-video-intel xorg-input-drivers xorg-minimal xorg-fonts

Usuários e Senhas.

Tendo instalado o Xorg básico, trate de definir a senha de root:

(chroot) bash-4.4# passwd root

Crie o seu usuário normal:

(chroot) bash-4.4# useradd -m -s /bin/bash -U -G wheel,users,audio,video,cdrom,input edps
(chroot) bash-4.4# passwd edps

BSPWM na veia!

E para finalizar, eu como ambiente gráfico optei pelo BSPWM, então fiz assim:

(chroot) bash-4.4# xbps-install -S alsa-lib alsa-utils dbus sv-helper polkit bspwm sxhkd polybar rofi dmenu j4-dmenu-desktop leafpad sakura dunst numlockx compton nitrogen ranger conky

Como gerenciador de arquivos optei pelo Thunar, faça uma busca com:

(chroot) bash-4.4# xbps-query -Rs 'thunar'
[-] Thunar-1.8.9_1                   Thunar File Manager
[-] Thunar-devel-1.8.9_1             Thunar File Manager - development files
[-] thunar-archive-plugin-0.4.0_1    Create and extract archives in Thunar
[-] thunar-media-tags-plugin-0.3.0_1 Adds special features for media files to the Thu...
[-] thunar-volman-0.9.5_1            Thunar Volume Manager

Então dá para se ver que preciso de 4 dos pacotes acima e do tumbler, logo:

(chroot) bash-4.4# xbps-install -S Thunar thunar-archive-plugin thunar-media-tags-plugin thunar-volman tumbler

Saia do ambiente chroot:

(chroot) bash-4.4# exit

Adição do novo sistema ao Grub da distro atual.

Se quiser já adicione o Void ao Grub de seu sistema, o meu é o Slackware como já dito:

# grub-mkconfig -o /boot/grub/grub.cfg

Reinicie o PC e se tudo der certo seu Void iniciará, a partir daí você já pode dar uma lida nisso:

HOW-TO :: VOID LINUX (CONFIGURAÇÃO)

Serviços.

Basicamente, você precisará habilitar os servicos residentes em /etc/sv, exemplo para o caso do dbus, dhcpcd, polkit, consolekit, cgmanager:

# ln -sv /etc/sv/dbus /var/service/dbus
# ln -sv /etc/sv/polkitd /var/service/polkitd
# ln -sv /etc/sv/dhcpcd /var/service/dhcpcd
# ln -sv /etc/sv/consolekit /var/service/consolekit
# ln -sv /etc/sv/cgmanager /var/service/cgmanager

Assim, se você instalar um Display manager como o LXDM e habilitá-lo com:

# ln -sv /etc/sv/lxdm /var/service/lxdm

Automaticamente o ambiente gráfico iniciará!

Ambientes Desktops.

Pesquise por outros DEs e instale o que desejar, exemplo:

# xbps-query -Rs kde | grep meta
[-] kde5-5.15.0_1                         The kde 5 meta-package for Void Linux
[-] kde5-baseapps-19.08.0_1               KDE 5 base applications meta-package for Void Linux

Essses 2 pacotes sozinhos trarão o inferno pra terra, digo, todo o KDE5 pro seu Void (e seriam muito mais na listagem abaixo, porque já tenho algumas libs do KDE aqui, assim como o qt5):

Name                           Action    Version           New version            Download size
libical                        install   -                 3.0.4_2                259KB 
bluez                          install   -                 5.50_5                 806KB 
bluez-qt5                      install   -                 5.61.0_1               203KB 
bluedevil                      install   -                 5.16.4_1               330KB 
breeze-gtk                     install   -                 5.16.4_1               209KB 
kpackage                       install   -                 5.61.0_1               157KB 
kdeclarative                   install   -                 5.61.0_1               200KB 
kcmutils                       install   -                 5.61.0_1               248KB 
qt5-plugin-mysql               install   -                 5.13.0_4               24KB 
libodbc                        install   -                 2.3.7_2                160KB 
qt5-plugin-odbc                install   -                 5.13.0_4               33KB 
postgresql-libs                install   -                 9.6.15_1               178KB 
qt5-plugin-pgsql               install   -                 5.13.0_4               27KB 
qt5-plugin-sqlite              install   -                 5.13.0_4               24KB 
unixodbc                       install   -                 2.3.7_2                33KB 
freetds                        install   -                 1.1.6_2                412KB 
qt5-plugin-tds                 install   -                 5.13.0_4               18KB 
kactivities5                   install   -                 5.61.0_1               106KB 
kworkspace                     install   -                 5.16.4_1               37KB 
kpty                           install   -                 5.61.0_1               36KB 
kdesu                          install   -                 5.61.0_1               60KB 
kde-cli-tools                  install   -                 5.16.4_1               788KB 
knewstuff                      install   -                 5.61.0_1               615KB 
kde-gtk-config5                install   -                 5.16.4_1               196KB 
qt5-quickcontrols              install   -                 5.13.0_4               569KB 
qt5-graphicaleffects           install   -                 5.13.0_4               52KB 
qt5-multimedia                 install   -                 5.13.0_4               642KB 
kwayland                       install   -                 5.61.0_1               384KB 
plasma-framework               install   -                 5.61.0_1               3251KB 
kunitconversion                install   -                 5.61.0_1               765KB 
threadweaver                   install   -                 5.61.0_1               49KB 
krunner                        install   -                 5.61.0_1               107KB 
kholidays                      install   -                 5.61.0_1               201KB 
kross                          install   -                 5.61.0_1               329KB 
kdeplasma-addons5              install   -                 5.16.4_1               806KB 
kgamma5                        install   -                 5.16.4_1               131KB 
libraw1394                     install   -                 2.1.2_1                21KB 
kinfocenter                    install   -                 5.16.4_1               1538KB 
libkscreen                     install   -                 5.16.4_1               250KB 
kscreen                        install   -                 5.16.4_1               234KB 
ksshaskpass                    install   -                 5.16.4_1               19KB 
libksysguard                   install   -                 5.16.4_1               579KB 
ksysguard                      install   -                 5.16.4_1               624KB 
socat                          install   -                 1.7.3.3_2              162KB 
kwallet-pam                    install   -                 5.16.4_1               9404B 
kidletime                      install   -                 5.61.0_1               26KB 
kwayland-integration           install   -                 5.16.4_1               26KB 
kwrited                        install   -                 5.16.4_1               13KB 
frameworkintegration           install   -                 5.61.0_1               1570KB 
kdecoration                    install   -                 5.16.4_1               48KB 
oxygen                         install   -                 5.16.4_1               4525KB 
khotkeys                       install   -                 5.16.4_1               1949KB 
kmenuedit                      install   -                 5.16.4_1               914KB 
polkit-kde-agent               install   -                 5.16.4_1               52KB 
openresolv                     install   -                 3.9.1_1                17KB 
wpa_supplicant                 install   -                 2.9_1                  939KB 
libnm                          install   -                 1.18.2_2               649KB 
oniguruma                      install   -                 6.9.3_1                133KB 
slang                          install   -                 2.3.2_2                695KB 
newt                           install   -                 0.52.21_1              57KB 
libndp                         install   -                 1.7_1                  14KB 
libmm-glib                     install   -                 1.10.4_1               210KB 
NetworkManager                 install   -                 1.18.2_2               2802KB 
networkmanager-qt5             install   -                 5.61.0_1               430KB 
knotifyconfig                  install   -                 5.61.0_1               72KB 
powerdevil                     install   -                 5.16.4_1               787KB 
qt5-quickcontrols2             install   -                 5.13.0_4               1674KB 
kirigami2                      install   -                 5.61.0_1               176KB 
kactivities5-stats             install   -                 5.61.0_1               71KB 
kjs                            install   -                 5.61.0_1               333KB 
khtml                          install   -                 5.61.0_1               2550KB 
systemsettings                 install   -                 5.16.4_1               287KB 
kactivitymanagerd              install   -                 5.16.4_1               162KB 
breeze-icons                   install   -                 5.61.0_1               7875KB 
breeze                         install   -                 5.16.4_1               14MB 
kinit                          install   -                 5.61.0_1               106KB 
qt5-sensors                    install   -                 5.13.0_4               138KB 
kscreenlocker                  install   -                 5.16.4_1               174KB 
kwin                           install   -                 5.16.4_1               6421KB 
milou                          install   -                 5.16.4_1               67KB 
qqc2-desktop-style             install   -                 5.61.0_1               60KB 
plasma-integration             install   -                 5.16.4_1               127KB 
xcb-proto                      install   -                 1.13_2                 86KB 
xorgproto                      install   -                 2019.1_1               531KB 
libXdmcp-devel                 install   -                 1.1.3_1                9848B 
libXau-devel                   install   -                 1.0.9_1                8080B 
libxcb-devel                   install   -                 1.13.1_2               330KB 
libqrencode                    install   -                 4.0.2_1                18KB 
libdmtx                        install   -                 0.7.5_1                38KB 
prison                         install   -                 5.61.0_1               27KB 
qt5-xmlpatterns                install   -                 5.13.0_4               960KB 
syntax-highlighting            install   -                 5.61.0_1               1330KB 
http-parser                    install   -                 2.9.2_1                13KB 
libgit2                        install   -                 0.28.3_1               417KB 
ktexteditor                    install   -                 5.61.0_1               2369KB 
kjsembed                       install   -                 5.61.0_1               358KB 
libqalculate-data              install   -                 3.3.0_2                80KB 
libqalculate                   install   -                 3.3.0_2                1049KB 
kitemmodels                    install   -                 5.61.0_1               84KB 
poppler-qt5                    install   -                 0.79.0_1               135KB 
libzip                         install   -                 1.5.2_2                63KB 
ebook-tools                    install   -                 0.2.2_3                21KB 
exiv2                          install   -                 0.27.0_1               828KB 
kfilemetadata5                 install   -                 5.61.0_1               160KB 
lmdb                           install   -                 0.9.24_1               64KB 
baloo5                         install   -                 5.61.0_1               456KB 
plasma-workspace               install   -                 5.16.4_1               6344KB 
kpeople                        install   -                 5.61.0_1               116KB 
kemoticons                     install   -                 5.61.0_1               1644KB 
python3-xdg                    install   -                 0.26_1                 31KB 
ibus                           install   -                 1.5.20_5               614KB 
plasma-desktop                 install   -                 5.16.4_1               11MB 
mobile-broadband-provider-info install   -                 20190116_1             40KB 
modemmanager-qt5               install   -                 5.61.0_1               154KB 
qca-qt5                        install   -                 2.1.3_8                519KB 
vpnc-scripts                   install   -                 20190425_1             8064B 
libpcsclite                    install   -                 1.8.25_1               22KB 
openconnect                    install   -                 8.04_1                 451KB 
plasma-nm                      install   -                 5.16.4_1               1250KB 
plasma-pa                      install   -                 5.16.4_1               199KB 
plasma-sdk                     install   -                 5.16.4_1               359KB 
plasma-workspace-wallpapers    install   -                 5.16.4_1               33MB 
sddm                           install   -                 0.18.1_1               3441KB 
sddm-kcm                       install   -                 5.16.4_1               107KB 
accountsservice                install   -                 0.6.55_1               118KB 
libcracklib                    install   -                 2.9.7_1                - 
libpwquality                   install   -                 1.4.0_1                - 
user-manager                   install   -                 5.16.4_1               416KB 
libpipewire                    install   -                 0.2.6_1                83KB 
xdg-desktop-portal-kde         install   -                 5.16.4_1               184KB 
kde5                           install   -                 5.15.0_1               792B 
kdnssd                         install   -                 5.61.0_1               73KB 
libssh                         install   -                 0.8.7_2                182KB 
ilmbase                        install   -                 2.3.0_1                66KB 
libopenexr                     install   -                 2.3.0_1                553KB 
kio-extras                     install   -                 19.04.3_1              1035KB 
baloo-widgets5                 install   -                 19.08.0_1              123KB 
dolphin                        install   -                 19.08.0_1              4034KB 
kate5                          install   -                 19.08.0_1              6764KB 
grantlee5                      install   -                 5.1.0_4                277KB 
libxapian                      install   -                 1.4.11_2               656KB 
khelpcenter                    install   -                 19.08.0_1              4338KB 
konsole                        install   -                 19.08.0_1              1153KB 
kde5-baseapps                  install   -                 19.08.0_1              644B 

Size to download:              152MB
Size required on disk:         651MB
Space available on disk:        29GB

Do you want to continue? [Y/n] 

Logo se escolher esse elefante, esqueça o caso do LXDM, porque o KDE já tem o SSDM com esse propósito, ou seja, acho que para habilitá-lo você deve usar:

# ln -sv /etc/sv/ssdm /var/service/ssdm

Para o caso do outro elefante branco, o Gnome sHELL, você pode tê-lo por completo, incluindo quatrocentas toneladas de joguinhos boçais digitanto isso (aqui são 319 pacotes, fora alguns que tenho instalados):

# xbps-install gnome gnome-apps gnome-games-collection

Apenas digitando o comando abaixo, dá para se ter uma ideia do que é possível instalar tendo em vista que a maioria dos grandes DEs possuem meta-pacotes (exceto o Cinnamon, Enlightenment, etc) esses você deve pesquisar pelo nome:

$ xbps-query -Rs meta-package          
[-] breeze-cursors-1.0_1            Breeze Cursors meta-package
[-] compiz-reloaded-0.8.12_1        Compiz window manager meta-package
[-] git-all-2.23.0_1                Git Tree History Storage Tool - meta-pac...
[-] gnome-3.32.0_1                  GNOME meta-package for Void Linux
[-] gnome-apps-3.32.0_1             GNOME-Apps meta-package for Void Linux
[-] gnome-games-collection-3.32.0_1 GNOME Games Collection meta-package for ...
[-] kde5-5.15.0_1                   The kde 5 meta-package for Void Linux
[-] kde5-baseapps-19.08.0_1         KDE 5 base applications meta-package for...
[-] kodi-binary-addons-18.3_1       Meta-package for binary kodi addons
[-] lxde-0.5.0_15                   The LXDE meta-package for Void Linux
[-] lxqt-0.14.0_2                   LXQt meta-package for Void Linux
[*] mate-1.20.0_3                   The MATE meta-package for Void Linux
[*] mate-extra-1.18.0_1             The MATE extras meta-package for Void Linux
[-] wifi-firmware-1.3_3             WiFi firmware meta-package
[-] xfce4-4.14.0_1                  XFCE meta-package for Void Linux
[-] xorg-7.6_5                      X.org meta-package
[*] xorg-input-drivers-7.6_4        X.org input drivers meta-package
[*] xorg-minimal-1.2_2              Xorg meta-package including xorg-xserver...
[-] xorg-video-drivers-7.6_18       X.org video drivers meta-package

Agora vou-me-já!…

How-To :: instalação do Void Linux (chroot)

3 comentários sobre “How-To :: instalação do Void Linux (chroot)

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s