Dica :: conflito de slots no Gentoo.


Confesso que tem horas que não estou com paciência para lidar com o Gentoo e essa atualização do Portage já vinha se arrastando a mais de um mês, até que hoje perdi um tempinho para resolvê-la.

O problema em si reside no fato de que se o portage não for atualizado o sistema todo também não será, a falta de paciência não nos deixa enxergar o óbio que pode ser visto na mensagem abaixo (ou como diz o nosso amigo @albfneto, o Portage nos diz o que fazer a maior parte do tempo) 😉

Pois bem, na imagem acima se vê a mensagem de conflito de slots e vemos duas versões do Portage listadas, sendo que a atual (e que seria atualizada) é requerida pelo pacote app-portage/gentoolkit, bingo! bastou removê-lo e aí sim pude atualizar o portage:

$ sudo emerge --ask --unmerge app-portage/gentoolkit
$ sudo emerge --oneshot sys-apps/portage

Com isso pude atualizar o sistema por completo (digo pude, porque são mais de 230 pacotes) e ainda estou na metade! kkk

IntÈ!

Dica :: conflito de slots no Gentoo.

2 comentários sobre “Dica :: conflito de slots no Gentoo.

    1. Pois é Alberto, não fosse o Gentoo o sistema que tá no meio do HD eu o teria removido a um tempo atrás, ficando só com o Slack e o Void!

      Mas é como eu disse: questão de ter tempo e paciência, o sistema é bem básico, menos de 1000 pacotes, um ou outro pacote que é da unstable, não uso layman, então não tem porque quebrar de repente.

      Curtir

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s