Debian + KDE com Compiz e Emerald


Esta dica pode ser tratada como um complemento à dica Compiz e Emerald no Debian Wheezy, porém, foi executada no Debian SID/Unstable com KDE 4.10.5 (o que não quer dizer que não funcione no Wheezy ou Jessie!), para todos os casos, basta seguir os passos da dica referenciada, ou seja, façam uso do repositório unstable para a instalação dos pacotes do Compiz e baixem e instalem manualmente os pacotes do Emerald.

Instalando no Debian SID com KDE.

# apt-get update
# apt-get install compiz compizconfig-backend-kconfig compizconfig-settings-manager compiz-fusion-plugins-extra compiz-fusion-plugins-main compiz-fusion-plugins-unsupported compiz-plugins fusion-icon

Este slideshow necessita de JavaScript.

A instalação do Emerald pode ser vista na dica original:

Compiz e Emerald no Debian Wheezy.

Tendo instalado os programas, prossigam com os passos abaixo:

Tecle Alt+F2 e digite ccsm, configure as opções de seu interesse, ao final tecle Alt+F2 novamente e digite fusion-icon:

Clique no ícone do fusion-icon e na opção Select Window Decorator, escolha Emerald, em seguida na opção Select Window Manager, escolha Compiz e para finalizar clique em Reload Window Manager:

Para iniciar o Compiz junto ao KDE, abra as Configurações do Sistema (SystemSettings) e vá na aba Administração do Sistema > Inicialização e Desligamento > Iniciar automaticamente, clique em adicionar programa, escreva fusion-icon e pronto!:

compiz-KDE-004

Ao reiniciar sua sessão KDE o Compiz entrará normalmente substituindo o Kwin.

Este slideshow necessita de JavaScript.

Anúncios
Debian + KDE com Compiz e Emerald

13 comentários sobre “Debian + KDE com Compiz e Emerald

  1. mcnd2 disse:

    Aprecio a beleza do compiz a tempo, e sempre o uso para deixar essa beleza de frente aos meus olhos. Mais é claro, tudo isso numa máquina que rode tranquilo o 3D, caso não, tá merda.

    Nesse mesmo sistema, quando o kde o possuía, sempre rolou o kwin e também me satisfez ao seu uso, com um pouquinho de aprendizado em suas configs, não havendo a necessidade de colocar o compiz. Sabemos.

    Mais agora já exterminei o kde completamente e usufruo da leveza do xfce e esse, lógico, já tem o compiz instalado. O problema é que o ‘fusion-icon’ não tá carregando ( http://vivaolinux.com.br/topico/Debian/Fusion-Icon-nao-carrega ). De qualquer maneira estou com ele, o compiz, rodando numa boa.

    Fora o dito acima, esta de muito bom seu artigo. Parabéns…

    Curtir

  2. edps disse:

    A quem possa interessar…

    pelo menos aqui, em toda as vezes que usei COmpiz no KDE (e vale para todas as distros) sempre tive melhor desempenho usando Compiz no KDE ao invés dos efeitos nativos do Kwin?

    Curtir

  3. Hunter disse:

    edps se liga no meu erro:

    apt-get -t unstable install compiz compiz-gtk compizconfig-backend-gconf compizconfig-settings-manager compiz-plugins compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-fusion-plugins-unsupported fusion-ico

    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    O pacote compiz não está disponível, mas é referenciado por outro pacote.
    Isto pode significar que o pacote está faltando, ficou obsoleto ou
    está disponível somente a partir de outra fonte

    E: O pacote ‘compiz’ não tem candidato para instalação
    E: Impossível encontrar o pacote compiz-gtk
    E: Impossível encontrar o pacote compizconfig-backend-gconf
    E: Impossível encontrar o pacote compizconfig-settings-manager
    E: Impossível encontrar o pacote compiz-plugins
    E: Impossível encontrar o pacote compiz-fusion-plugins-main
    E: Impossível encontrar o pacote compiz-fusion-plugins-extra
    E: Impossível encontrar o pacote compiz-fusion-plugins-unsupported
    E: Impossível encontrar o pacote fusion-ico

    root@Pc-hunter:/# apt-get update
    Atingido http://linorg.usp.br wheezy Release.gpg
    Atingido http://linorg.usp.br wheezy-updates Release.gpg
    Atingido http://debian.c3sl.ufpr.br wheezy/updates Release.gpg
    Atingido http://debian.c3sl.ufpr.br wheezy/updates Release
    Atingido http://linorg.usp.br wheezy-backports Release.gpg
    Atingido http://linorg.usp.br wheezy Release
    Atingido http://debian.c3sl.ufpr.br wheezy/updates/main amd64 Packages
    Atingido http://linorg.usp.br wheezy-updates Release
    Atingido http://debian.c3sl.ufpr.br wheezy/updates/contrib amd64 Packages
    Atingido http://linorg.usp.br wheezy-backports Release
    Atingido http://debian.c3sl.ufpr.br wheezy/updates/non-free amd64 Packages
    Atingido http://linorg.usp.br wheezy/main amd64 Packages
    Atingido http://linorg.usp.br wheezy/contrib amd64 Packages
    Ign http://mcrapet.free.fr unstable/ Release.gpg
    Atingido http://linorg.usp.br wheezy/non-free amd64 Packages
    Atingido http://linorg.usp.br wheezy-updates/main amd64 Packages
    Atingido http://dl.google.com stable Release.gpg
    Obter:1 http://security.debian.org wheezy/updates Release.gpg [836 B]
    Atingido http://linorg.usp.br wheezy-updates/contrib amd64 Packages
    Obter:2 http://security.debian.org wheezy/updates Release [102 kB]
    Atingido http://linorg.usp.br wheezy-updates/non-free amd64 Packages
    Atingido http://linorg.usp.br wheezy-backports/main amd64 Packages
    Atingido http://linorg.usp.br wheezy-backports/contrib amd64 Packages
    Obter:3 http://ftp.debian.org wheezy Release.gpg [1.672 B]
    Atingido http://linorg.usp.br wheezy-backports/non-free amd64 Packages
    Atingido http://ftp.us.debian.org sid Release.gpg
    Obter:4 http://download.virtualbox.org wheezy Release.gpg [198 B]
    Obter:5 http://security.debian.org wheezy/updates/main amd64 Packages [106 kB]
    Atingido http://ftp.us.debian.org sid Release
    Ign http://mcrapet.free.fr unstable/ Release
    Atingido http://download.virtualbox.org wheezy Release
    Ign http://download.virtualbox.org wheezy Release
    Obter:6 http://ftp.debian.org wheezy Release [167 kB]
    Obter:7 http://ppa.launchpad.net raring Release.gpg [316 B]
    Obter:8 http://security.debian.org wheezy/updates/contrib amd64 Packages [14 B]
    Atingido http://ftp.us.debian.org sid/main amd64 Packages
    Obter:9 http://security.debian.org wheezy/updates/non-free amd64 Packages [14 B]
    Atingido http://download.virtualbox.org wheezy/contrib amd64 Packages
    Atingido http://dl.google.com stable Release
    Atingido http://ftp.us.debian.org sid/non-free amd64 Packages
    Obter:10 http://ppa.launchpad.net raring Release.gpg [316 B]
    Atingido http://ftp.us.debian.org sid/contrib amd64 Packages
    Atingido http://mcrapet.free.fr unstable/ Packages
    Atingido http://dl.google.com stable/main amd64 Packages
    Atingido http://ppa.launchpad.net raring Release
    Ign http://ppa.launchpad.net raring Release
    Atingido http://ppa.launchpad.net raring Release
    Ign http://ppa.launchpad.net raring Release
    Atingido http://ppa.launchpad.net raring/main amd64 Packages
    Atingido http://ppa.launchpad.net raring/main amd64 Packages
    Obter:11 http://ftp.debian.org wheezy/main amd64 Packages [5.848 kB]
    Obter:12 http://ftp.debian.org wheezy/contrib amd64 Packages [42,0 kB]
    Obter:13 http://ftp.debian.org wheezy/non-free amd64 Packages [80,8 kB]
    Baixados 6.350 kB em 14s (437 kB/s)
    E: O Dynamic MMap ficou sem espaço. Por favor aumente o tamanho de APT::Cache-Start. Valor actual: 30408704. (man 5 apt.conf)
    Lendo listas de pacotes… Erro!
    W: Erro GPG: http://download.virtualbox.org wheezy Release: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY 54422A4B98AB5139
    W: Erro GPG: http://ppa.launchpad.net raring Release: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY A5D712AEE06E6293
    W: Erro GPG: http://ppa.launchpad.net raring Release: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY C2518248EEA14886
    E: Não foi possível aumentar o tamanho do MMap pois o limite de 30000000 bytes já foi alcançado.
    E: O Dynamic MMap ficou sem espaço. Por favor aumente o tamanho de APT::Cache-Start. Valor actual: 30408704. (man 5 apt.conf)
    E: Ocorreu um erro ao processar libpam-shishi (NewFileVer1)
    E: Problem with MergeList /var/lib/apt/lists/ftp.debian.org_debian_dists_wheezy_main_binary-amd64_Packages
    E: As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.
    root@Pc-hunter:/# apt-get install compiz compizconfig-backend-kconfig compizconfig-settings-manager compiz-fusion-plugins-extra compiz-fusion-plugins-main compiz-fusion-plugins-unsupported compiz-plugins fusion-icon
    E: O Dynamic MMap ficou sem espaço. Por favor aumente o tamanho de APT::Cache-Start. Valor actual: 30408704. (man 5 apt.conf)
    Lendo listas de pacotes… Erro!
    E: Não foi possível aumentar o tamanho do MMap pois o limite de 30000000 bytes já foi alcançado.
    E: O Dynamic MMap ficou sem espaço. Por favor aumente o tamanho de APT::Cache-Start. Valor actual: 30408704. (man 5 apt.conf)
    E: Ocorreu um erro ao processar libpam-shishi (NewFileVer1)
    E: Problem with MergeList /var/lib/apt/lists/ftp.debian.org_debian_dists_wheezy_main_binary-amd64_Packages
    E: As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.

    Curtir

  4. Hunter disse:

    grande mano, o meu /etc/apt/sources.list esta assim:

    ### Debian 7.1 Wheezy.
    ### Chave GPG: apt-get install debian-archive-keyring
    deb http://linorg.usp.br/debian/ wheezy main contrib non-free

    ### Debian 7.1 Wheezy Security ‘Updates’.
    deb http://debian.c3sl.ufpr.br/debian-security/ wheezy/updates main contrib non-free

    ### Debian 7.1 Wheezy Updates ‘Volatile’.
    deb http://linorg.usp.br/debian/ wheezy-updates main contrib non-free

    ### Debian 7.1 Wheezy ‘Backports’.
    deb http://linorg.usp.br/debian/ wheezy-backports main contrib non-free

    ### Debian Mozilla Team.
    ### Chave GPG: apt-get update; apt-get –allow-unauthenticated install pkg-mozilla-archive-keyring; apt-get update
    deb http://mozilla.debian.net/ wheezy-backports iceweasel-aurora

    ### Repositório deb-multimedia.
    ### Chave GPG: apt-get update; apt-get –allow-unauthenticated install deb-multimedia-keyring; apt-get update
    #deb http://www.deb-multimedia.org wheezy main non-free

    ————————————————————————————————————————

    e vc falara para utilisarmos o repositório Debian SID/Unstable no arquivo /etc/apt/sources.list e o deixa-lo assim… não entendi teria que apagar tudo e deixar so isso aqui? o que seria esse SID/Unstabke.
    eu só conheço o caminha da sources.list da maneira citada acima…
    Bro desculpa as perguntas são duvidas de um cara que entrou a pouco no universo linux…
    abraço

    deb http://ftp.debian.org/debian/ sid main contrib non-free
    deb http://ftp.debian.org/debian/ wheezy main contrib non-free
    deb http://security.debian.org/ wheezy/updates main contrib non-free

    Curtir

    1. edps disse:

      VOcê adiciona esses 3 repos, ou seja, vai somar aos que já existem, daí você instala os pacotes necessários e ao final comenta ou remove esse 3 repos, do contrário seu Debian será atualizado pro SID/Unstable, o qual você mesmo pode descobrir o que é pesquisando na Net, lembre-se que aqui não é um fórum, só responderei quando puder ou quiser.

      Curtir

      1. Hunter disse:

        Tranquilidade… tamo junto afinal ninguém é de ferro vc deve receber uma renca de perguntas kkkk… e ainda tem sua vida pessoal eu entendo… só por favor não pare com os artigos… seu trabalho é muito bom e a comunidade de precisa de pessoas como vc pra fomentar o conhecimento e a formação de outras pessoas iguais a vc abraço…

        Curtir

  5. Hunter disse:

    Bro…
    consegui eliminar o problema do “Dynamic MMap” da seguinte forma…

    – Editei o “apt.conf’

    # /etc/apt# nano apt.conf

    PT::Default-Release wheezy-backports;
    APT::Get::Purge 1;
    APT::Cache-Limit 61440000; <—————————- alterei com este valor e pronto.
    APT::Get::AllowUnauthenticated 0;
    APT::Get::AutomaticRemove 1;
    APT::Get::HideAutoRemove 1;
    APT::Install-Recommends 0;
    APT::Install-Suggests 0;
    Aptitude::Recommends-Important 0;
    Debug::pkgAutoRemove 0;
    Acquire::Languages none;
    Acquire::cdrom {
    mount "/media/cdrom";
    };
    Dir::Media::MountPath "/media/cdrom";
    Acquire::PDiffs 0;
    Acquire::http::timeout 10;
    DPkg
    {
    Options {–force-overwrite;}
    }

    salvei e logo em seguida um : "apt-get update" pra conferir!!!

    Curtir

      1. Hunter disse:

        bro é o que eu tenho que vc acha????

        #

        # deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ – Official amd64 kde-CD Binary-1 20130615-23:04]$

        ################ PARTE ORIGINAL DO SOURCE.LIST #################
        #deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ – Official amd64 kde-CD Binary-1 20130615-23:04]/$

        #deb http://linorg.usp.br/debian/ wheezy main
        #deb-src http://linorg.usp.br/debian/ wheezy main

        #deb http://security.debian.org/ wheezy/updates main
        #deb-src http://security.debian.org/ wheezy/updates main

        # wheezy-updates, previously known as ‘volatile’
        #deb http://linorg.usp.br/debian/ wheezy-updates main
        #deb-src http://linorg.usp.br/debian/ wheezy-updates main

        ### FIM ORIGINAL
        #################################################################

        ###### Debian Squeeze sources.list ######

        ### Debian 7.1 Wheezy.
        ### Chave GPG: apt-get install debian-archive-keyring
        deb http://linorg.usp.br/debian/ wheezy main contrib non-free

        ### Debian 7.1 Wheezy Security ‘Updates’.
        deb http://debian.c3sl.ufpr.br/debian-security/ wheezy/updates main contrib non-free

        ### Debian 7.1 Wheezy Updates ‘Volatile’.
        deb http://linorg.usp.br/debian/ wheezy-updates main contrib non-free

        ### Debian 7.1 Wheezy ‘Backports’.
        deb http://linorg.usp.br/debian/ wheezy-backports main contrib non-free

        ### Debian Mozilla Team.
        ### Chave GPG: apt-get update; apt-get –allow-unauthenticated install pkg-mozilla-archive-ke$
        #deb http://mozilla.debian.net/ wheezy-backports iceweasel-aurora

        ### Repositório deb-multimedia.
        ### Chave GPG: apt-get update; apt-get –allow-unauthenticated install deb-multimedia-keyring$
        #deb http://www.deb-multimedia.org wheezy main non-free

        Curtir

  6. Hunter disse:

    Bro estou com outra zica aqui se liga neste erro:

    GOSTARIA DE ENTENDER ESTE ERRO AQUI:
    W: Erro GPG: http://download.virtualbox.org wheezy Release: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY 54422A4B98AB5139

    ESTE AQUI TAMBEM:
    W: Erro GPG: http://ppa.launchpad.net raring Release: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY A5D712AEE06E6293

    ESTE AQUI TAMBEM:
    W: Erro GPG: http://ppa.launchpad.net raring Release: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY C2518248EEA14886

    root@Pc-hunter:/# apt-get install compiz compizconfig-backend-kconfig compizconfig-settings-manager compiz-fusion-plugins-extra compiz-fusion-plugins-main compiz-fusion-plugins-unsupported compiz-plugins fusion-icon
    Lendo listas de pacotes… Pronto
    Construindo árvore de dependências
    Lendo informação de estado… Pronto
    O pacote compiz não está disponível, mas é referenciado por outro pacote.
    Isto pode significar que o pacote está faltando, ficou obsoleto ou
    está disponível somente a partir de outra fonte

    E ESTE AQUI… O PORQUE NÃO INSTALA ESSA BAGAÇA:
    E: O pacote ‘compiz’ não tem candidato para instalação
    E: Impossível encontrar o pacote compizconfig-backend-kconfig
    E: Impossível encontrar o pacote compizconfig-settings-manager
    E: Impossível encontrar o pacote compiz-fusion-plugins-extra
    E: Impossível encontrar o pacote compiz-fusion-plugins-main
    E: Impossível encontrar o pacote compiz-fusion-plugins-unsupported
    E: Impossível encontrar o pacote compiz-plugins
    E: Impossível encontrar o pacote fusion-icon

    ESTOU PROCURANDO ATE AGORA NADA…
    SE ENCONTRAR É NOIS… POST HERE…
    ABRAÇO.

    Curtir

    1. edps disse:

      Os primeiros são erros de chaves GPG, em todos os meus sources.list eu acrescento as chaves abaixo do nome do repositório, exemplo do VirtualBox:

      ### Oracle VM VirtualBox.
      ### Chave GPG: wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | sudo apt-key add –
      deb http://download.virtualbox.org/virtualbox/debian/ wheezy contrib

      Então meu fio, tasca aí:

      $ wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | sudo apt-key add –

      difícil?

      Amigão, se você leu mesmo essa dica, saberia que tem que usar os repositórios desta outra dica (só para instalar):

      http://gnutwoall.wordpress.com/2013/05/06/compiz-e-emerald-no-debian-wheezy/

      Curtir

  7. edps disse:

    @Hunter, deixe seu sources.list assim:

    ### Debian 7.1 Wheezy.
    ### Chave GPG: apt-get install debian-archive-keyring
    deb http://linorg.usp.br/debian/ wheezy main contrib non-free

    ### Debian 7.1 Wheezy Security ‘Updates’.
    deb http://debian.c3sl.ufpr.br/debian-security/ wheezy/updates main contrib non-free

    ### Debian 7.1 Wheezy Updates ‘Volatile’.
    deb http://linorg.usp.br/debian/ wheezy-updates main contrib non-free

    ### Debian 7.1 Wheezy ‘Backports’.
    deb http://linorg.usp.br/debian/ wheezy-backports main contrib non-free

    ### Debian Mozilla Team.
    ### Chave GPG: apt-get update; apt-get –allow-unauthenticated install pkg-mozilla-archive-ke$
    deb http://mozilla.debian.net/ wheezy-backports iceweasel-aurora

    ### Repositório deb-multimedia.
    ### Chave GPG: apt-get update; apt-get –allow-unauthenticated install deb-multimedia-keyring$
    deb http://www.deb-multimedia.org wheezy main non-free

    ### Debian SID/Unstable.
    deb http://ftp.debian.org/debian/ sid main contrib non-free

    Rode um:

    # apt-get update

    Instale os pacotes do Compiz e ao final remova a linha:

    ### Debian SID/Unstable.
    deb http://ftp.debian.org/debian/ sid main contrib non-free

    * porque se não removê-la ( ou comentá-la com # ) no futuro ao atualizar o sistema com ( apt-get dist-upgrade ) você acabará por atualizar todo seu Debian para a árvore instável de pacotes.

    Curtir

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s